Project

General

Profile

Bug #2469

Upgrade to Greyhole 0.15.15

Added by bigfoot65 27 days ago. Updated 18 days ago.

Status:
Assigned
Priority:
Normal
Assignee:
Target version:
-
Start date:
04/24/2022
Due date:
% Done:

0%


Description

Please upgrade Greyhole to 0.15.15:

https://github.com/gboudreau/Greyhole/releases/download/0.15.15/greyhole-0.15.15.tar.gz

  • Fix for PHP 8.1
  • Better handling of locked files/share in a frozen directory
  • Optimization (and logging at PERF level) in code that handles close tasks logged by VFS module Ref: #293

History

#1 Updated by cpg 27 days ago

  • Status changed from New to Feedback
  • Assignee set to bigfoot65
alpha.amahi.org/tmp/amahi-greyhole-0.15.15-1.x86_64.rpm

(for f27 only -- f35 is having trouble compiling the rpm still)

#2 Updated by bigfoot65 27 days ago

Testing overnight and will report results tomrrow.

#3 Updated by bigfoot65 21 days ago

  • Status changed from Feedback to Assigned
  • Assignee changed from bigfoot65 to cpg

Sorry, forgot to follow up with my testing.

All went well and recommend release to repo.

BTW, when will you be able to get an updated version complete for Fedora 35?

Last I recall, there were RPM compile issues.

#4 Updated by cpg 21 days ago

  • Status changed from Assigned to Feedback
  • Assignee changed from cpg to bigfoot65

ok, released the f27 version.

Yes, we had build issues with the f35 one. I worked around them (may come back to bite us later).

Please try the f35 version under the same url.

#5 Updated by bigfoot65 21 days ago

Tried the same URL and I get the following error:

[amahi@fedora ~]$ sudo rpm -Uvh http://alpha.amahi.org/tmp/amahi-greyhole-0.15.15-1.x86_64.rpm
Retrieving http://alpha.amahi.org/tmp/amahi-greyhole-0.15.15-1.x86_64.rpm
error: Failed dependencies:
        libasn1-samba4.so.8()(64bit) is needed by amahi-greyhole-0.15.15-1.x86_64
        libcom_err-samba4.so.0()(64bit) is needed by amahi-greyhole-0.15.15-1.x86_64
        libgssapi-samba4.so.2()(64bit) is needed by amahi-greyhole-0.15.15-1.x86_64
        libhcrypto-samba4.so.5()(64bit) is needed by amahi-greyhole-0.15.15-1.x86_64
        libheimbase-samba4.so.1()(64bit) is needed by amahi-greyhole-0.15.15-1.x86_64
        libhx509-samba4.so.5()(64bit) is needed by amahi-greyhole-0.15.15-1.x86_64
        libkrb5-samba4.so.26()(64bit) is needed by amahi-greyhole-0.15.15-1.x86_64
        libldb.so.1()(64bit) is needed by amahi-greyhole-0.15.15-1.x86_64
        libndr.so.0()(64bit) is needed by amahi-greyhole-0.15.15-1.x86_64
        libnetapi.so.0()(64bit) is needed by amahi-greyhole-0.15.15-1.x86_64
        libnsl.so.1()(64bit) is needed by amahi-greyhole-0.15.15-1.x86_64
        libroken-samba4.so.19()(64bit) is needed by amahi-greyhole-0.15.15-1.x86_64
        libsamba-credentials.so.0()(64bit) is needed by amahi-greyhole-0.15.15-1.x86_64
        libsmbd-conn-samba4.so()(64bit) is needed by amahi-greyhole-0.15.15-1.x86_64
        libsmbd_base.so()(64bit) is needed by amahi-greyhole-0.15.15-1.x86_64
        libutil-cmdline-samba4.so()(64bit) is needed by amahi-greyhole-0.15.15-1.x86_64
        libwind-samba4.so.0()(64bit) is needed by amahi-greyhole-0.15.15-1.x86_64
        libz-samba4.so()(64bit) is needed by amahi-greyhole-0.15.15-1.x86_64

#6 Updated by cpg 21 days ago

Thanks. The build machine did not have those libs, etc. and I missed tweaking for them. Please try again with the same url path to the rpm.

#7 Updated by bigfoot65 20 days ago

Ah. Installed without error. Will test and report back results.

#8 Updated by bigfoot65 18 days ago

  • Status changed from Feedback to Assigned
  • Assignee changed from bigfoot65 to cpg

Everything looks ok. Recommend release to repo.

Also available in: Atom