Project

General

Profile

Bug #2471

Upgrade to Amahi 12 on Fedora 36

Added by bigfoot65 about 1 month ago. Updated about 1 month ago.

Status:
New
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
05/15/2022
Due date:
% Done:

0%


Description

The upgrade from Fedora 35 to Fedora 36 went smooth. Amahi was uninstalled on upgrade for some reason too.

I tried to reinstall Amahi. However, Amahi 12 cannot be installed. I receive the following errors:

[amahi@fedora ~]$ sudo dnf -y install hda-ctl hda-platform
Last metadata expiration check: 0:01:45 ago on Sun 15 May 2022 07:50:45 PM CDT.
Error:
 Problem 1: conflicting requests
  - nothing provides libruby.so.3.0()(64bit) needed by hda-platform-11.9.2-1.x86_64
  - nothing provides libruby.so.3.0()(64bit) needed by hda-platform-11.9.3-1.x86_64
  - nothing provides libruby.so.3.0()(64bit) needed by hda-platform-11.9.4-1.x86_64
 Problem 2: conflicting requests
  - package hda-ctl-11.9.8-1.x86_64 requires hda-platform >= 11.7.0, but none of the providers can be installed
  - package hda-ctl-11.9.9-1.x86_64 requires hda-platform >= 11.7.0, but none of the providers can be installed
  - nothing provides libruby.so.3.0()(64bit) needed by hda-platform-11.9.2-1.x86_64
  - nothing provides libruby.so.3.0()(64bit) needed by hda-platform-11.9.3-1.x86_64
  - nothing provides libruby.so.3.0()(64bit) needed by hda-platform-11.9.4-1.x86_64
(try to add '--skip-broken' to skip uninstallable packages)

History

#1 Updated by bigfoot65 about 1 month ago

Based on the web site below, looks like hda-ctl/hda-platform needs to updated to reflect libruby.so.3.1.

https://rpmfind.net/linux/RPM/fedora/updates/36/x86_64/Packages/r/ruby-libs-3.1.2-164.fc36.x86_64.html

Also available in: Atom