Project

General

Profile

Bug #25

long name in samba leads to weird short ("msdos" style) name seen on a mac

Added by cpg over 11 years ago. Updated almost 11 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
file sharing
Target version:
-
Start date:
02/12/2009
Due date:
% Done:

100%


Description

recently, i ripped a boo on cd that i have. the directory produced is called

"Influencer - Patterson et al."

when i put it in my music share (via ssh from the linux machine that it ripped it),

i was surprised when i was looking for it from a mac, i see it with a directory name:

IN35EL~Z

why is that?

sounds like some encoding issue.

smb.conf View (2.19 KB) cpg, 02/12/2009 04:35 PM

History

#1 Updated by cpg over 11 years ago

i should mention that the directory is in an ext3 file system.

#2 Updated by obnox over 11 years ago

how do you see the file names when looking from windows clients ? and with smbclient ?

#3 Updated by cpg over 11 years ago

both from windows and smbclient i see the folder name as: IN35EL~Z

#4 Updated by obnox over 11 years ago

I can' reproduce that here, usually see the long file names.

hmm, please post your complete smb.conf file.
special attention to "*mangle*" and "*case*" options.

#5 Updated by cpg over 11 years ago

no mention of case or mangle. attached is my smb.conf.

#6 Updated by cpg over 11 years ago

  • Assignee set to cpg

Interesting, I did a couple more tests.

I created three test directories:

This is a Test.
This is another Test
YetAnotherTest.

their names end up appearing like:

TT5DER~4
This is another Test
Y2X2UV~O

from within the mac, i renamed the Y2X2UV~O file to YetAnotherTest. (with a dot at the end), which worked, and now i see it in linux as:

YetAnotherTest?

this is cut and pasted via the terminal in the mac into firefox and this bug tracker, so i don't expect it to show much.

#7 Updated by obnox over 11 years ago

Oh, I understand, the point is the trailing "." in the file name.
I need to investigate this - might be a bug.

#8 Updated by obnox over 11 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

ok, this is not a bug, it is a feature:

windows does not allow file names ending on a '.' character
(neither files ending on spaces).

this behaviour of samba ensures that these files will be accessible by CIFS clients at all...

#9 Updated by cpg almost 11 years ago

  • Status changed from Resolved to Closed

Also available in: Atom