Project

General

Profile

Bug #320

Knowledgetree generates errors when uploading or viewing files

Added by boomerang56 over 11 years ago. Updated over 11 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
10/01/2009
Due date:
% Done:

0%


Description

I get this error any time I upload a file - PDF and jpg, both less than half a meg.

Fatal error: Call to undefined function mb_ereg_replace() in /var/hda/web-apps/ktree/html/thirdparty/Smarty/plugins/modifier.sanitize_input.php on line 5

The document appears to get uploaded but trying to view it afterwards gets the same error.

To reproduce - log in to KT, then from the Dashboard click on Browse Folders ---> Upload Document
Click Browse, select a local file, choose "default" for the file type, and click ADD
Fill in metadata, click SAVE

This is when the error appears.

History

#1 Updated by boomerang56 over 11 years ago

  • Status changed from New to Resolved
  • Priority changed from Normal to Low

Solved - Fedora needs package php-mbstring-5.2.9-2.fc10, which is not installed by default.

More info here:

http://forums.knowledgetree.com/viewtopic.php?f=6&t=18968

Install this RPM, reboot the server and good to go.

Suggest this RPM needs to be installed as part of the automated install.

#2 Updated by cpg over 11 years ago

  • Status changed from Resolved to Feedback
  • Priority changed from Low to Normal

ok, the app has been now updated to include a dependency on php-mbstring.

can you uninstall the app and install again to make sure it works?

if it works, please come back here and set the status to closed!
(in that case, we will move the app to beta!)

if not, then set to assigned.

#3 Updated by boomerang56 over 11 years ago

  • Status changed from Feedback to Closed

Uninstalled the app, then reinstalled (much faster than the first time now that I had all the dependencies!).

Knowledgetree installed fine, then I tried uploading a document (scanned PDF), viewing it, checking it out, back in, deleting/restoring/expunging it. Just very basic touch testing. Seems to be OK so far.

Also available in: Atom