Project

General

Profile

Bug #344

Ethernet Connections issues

Added by pjcrux about 11 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Medium
Assignee:
-
Category:
hda-install
Target version:
-
Start date:
10/15/2009
Due date:
% Done:

0%


Description

Numerous users, to date 3 including bdfoster, pjcrux, and nitz369 have issues with Amahi after installation. Fedora installation works until Amahi is installed.

Currently affected Lan Chipsets:

Realtek 8211CL on an M3N78 PRO and M3N78-VM
GX260 Integrated chipset on an Intel 845G mobo.

nitz369's writeup:

Situation: Internet and Network work perfect before Amahi install. Nothing works after install.

1. Found out that eth0 was disabled for some reason and would not start. through checking some boxes in the Network settings for starting the card or restart seemed to have solved this issue, not card is activated and stays actived and gets an IP, still no Internet BUT I can Ping the router and other boxes on the network.

2. Checked settings in ifcfg-eth0, here what I found.
Subnet: 192.168.1.10 (HDA IP)
IP: 192.168.1.10 (HDA IP)
DNS: 192.168.1.10 (again HDA IP)
Gateway: 192.168.1.1
Is this correct?
I assumed the subnet was wrong and changed it to 255.255.225.0, still nothing, I also thought that maybe the DNS was wrong (not sure how the DNS server) works, I would assume that eth0 would need to have the real DNS settings from the router or at the very least have the Gateway IP (192.168.1.1), so I changed that to 192.168.1.1.
Jiola! I have internet and can ping router!

3. After changing IPs around I tested with http://hda, http://setup, and nothing, says hda not is running on this server and redirects to anything.com, hmmm.....

4. I then turned off DHCP in router to test some more, rebooted HDA after and then changed IP settings on client computer, Client computer gets IP and DNS perfectly, so we know HDA DHCP and DNS is working, all addresses appear to be right, BUT client cannot access internet.

5. Tried to follow the network troubleshooting on HDA.
Ping hda - good
ping router - good
ping outside ip - good
ping yahoo - good

pjcrux write up:

Situation: Internet and Network work perfect before Amahi install. Nothing works after install.

1. Found out that eth0 was disabled for some reason and would not start. through checking some boxes in the Network settings for starting the card or restart seemed to have solved this issue, not card is activated and stays actived and gets an IP, still no Internet BUT I can Ping the router and other boxes on the network.

2. Checked settings in ifcfg-eth0, here what I found.
Subnet: 255.255.255.0
IP: 192.168.1.10 (HDA IP)
DNS: 192.168.1.10 (again HDA IP)
Gateway: 192.168.1.1

3. After changing IPs around I tested with http://hda, http://setup, and nothing, says hda not is running on this server and redirects to anything.com, hmmm.....

History

#1 Updated by essary about 11 years ago

I believe the issue is that DHCPD isn't running.
With nitz369, the configuration file wasn't being accepted by the version of bind that was installed with Fedora 10.
We fixed the issue by adding a nameserver in the HDA's /etc/resolv.conf file and then updating BIND. After that, we were able to get dhcpd running and then remove the nameserver in /etc/resolv.conf.

#2 Updated by cpg about 11 years ago

  • Priority changed from Medium to Urgent

is there

ONBOOT=yes

in the ifcfg-eth0 file?

#3 Updated by cpg about 11 years ago

  • Priority changed from Urgent to Medium

we still see this occacionally. have not been able to chase it down, tho!
downgrading to medium.

#4 Updated by pjcrux over 10 years ago

  • Status changed from New to Closed

Believe this to have been an issue with F10 and F11 this is no longer seen with F12. Closing, no updates for over 180 days.

Also available in: Atom