Project

General

Profile

Bug #375

Webmin HTTPS Setup

Added by snike3 over 11 years ago. Updated about 11 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
12/09/2009
Due date:
% Done:

0%


Description

Following the instructions found here: http://wiki.amahi.org/index.php/Webmin after installing Webmin from the Amahi setup page made it so https mode couldn't be enabled for Webmin. When the SSL enable option is set via the Webmin configuration page, it returns an error that the certification does not exist or doesn't contain the PEM information.

To fix this situation, Webmin was completely uninstalled by first running the uninstallation script it created on install and then uninstalled via the Amahi web interface. Then with the SSLeay package still installed, I performed the initial steps for setting up Webmin via Amahi. The webmin install script then automatically sets the http mode to SSL enabled. All that has to be done then is fix the http conf file to redirect to https.

History

#1 Updated by bigfoot65 about 11 years ago

Found a different method of making https work. The webmin ssl option can be set manually via command line. The wiki page has been updated accordingly. I may build a script to do all this and add it to the install script for users to run as root. Recommend this bug be closed.

#2 Updated by bigfoot65 about 11 years ago

  • Status changed from New to Closed

Script has been created to do https configuration and instructions provided for user. No further action required.

Also available in: Atom