Project

General

Profile

Bug #410

installer - amahi-installer -f creates 2 sets of config variables, prevents applications from appearing

Added by panthar over 10 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Medium
Assignee:
Category:
-
Target version:
-
Start date:
01/13/2010
Due date:
% Done:

0%


Description

I attempted to use amahi-installer with the "-f" option to force a reinstall to correct my internal domain name. Here is what happened:

- Ran "amahi-installer f"
Went to http://localhost:2000 in browser to complete the process
- The web installer informed me to delete /etc/sysconfig/amahi-hda, which I did
- The web installer then asked for my new key. I provided it and installation appeared to complete normally, asking for the reboot at the end.
- After reboot, when going to the Apps tab, there are no apps available to install, with the error message "There are no applications available at this time.
This could be due to a lack of network connectivity."

I then ran hda-settings, and it produced 2 sets of configuration variables. One from my original installation and one from the new one. So I'm guessing it's using the first set, including the old API key, and is not being allowed access to the applications.

History

#1 Updated by cpg over 10 years ago

  • Status changed from New to Closed
  • Assignee set to cpg
  • Priority changed from Normal to Medium

closed.

Applied in changeset 1b5609d88df7b1e84e6f72307a5ac1d319a018a9.

Also available in: Atom