Project

General

Profile

Bug #435

DNS server does not respond if IPV6 is enabled

Added by laz74 about 11 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
DNS
Target version:
-
Start date:
02/07/2010
Due date:
% Done:

0%


Description

Platform: Fedora 12, all current patches and updates
Amahi version: 5.1
Workstaion O/S: Windows 7

If IPV6 is enabled on a Windows7 pc then DNS server stops responding. DHCP addressing is handed out, and so is the DNS server. Server does respond to pings, but nslookup fails. Response comes back stating that DNS failed and then shows an IPV6 address. Cannot pullup the hda page by host name but can via IP address. If Win7 machine is rebooted then DNS works, but if machine goes to sleep then DNS fails. DNS is stable and reliable if connected via the hda SSL vpn client on the same Win7 machine. Disabled IPv6 on the Win7 machine and DNS started working with out a re-boot. IPconfig /renew (or /release) made no change as well Have an XP pro machine ont he network and it has had no DNS issues. I think that's everything I tried, if I think of anything else I'll update and if you need any logs let me know.

No_DNS.png View (114 KB) laz74, 02/07/2010 08:14 AM

History

#1 Updated by gboudreau about 11 years ago

Could you paste here what you get (the complete response) when you try to do a "nslookup hda", and it fails.
Thanks.

#2 Updated by laz74 about 11 years ago

Here is the nslookup hda you requested, as well as a IPconfig /all on the wireless interface. I did notice that when IPV6 is enabled it is the primary addressing (first in the list) so it may be the IPV6 address is hitting the server, and it stops responding to the requests. That or the IPV4 never goes out but then the IPv6 address is coming from somewhere (unless it's the equivalent of a Windows Default IP when a address isn't configured).

#3 Updated by gboudreau about 11 years ago

Please confirm that the ..c208 address used as DNS is the IPv6 address of your HDA ("ifconfig" on your HDA should tell you).

Did you make any change on your HDA to enable IPv6 on it? If so, could you please detail what you did?
My own HDA doesn't have an IPv6 address. All my clients and my router have IPv6 enabled, but my HDA does not send out any IPv6 addresses during DHCP leases.

#4 Updated by laz74 about 11 years ago

actually it isn't the IPv6 address of the server. fe80::211:11ff:fe99:d195/64 is the ipv6 address of the server not sure how IPV6 was enabled on the server. If I hard code the address to the wireless network adapter on the Win7 PC DNS still doesn't work. I don't know what that address is at all, nor what it is on my network. I do have a network firewall, but it doesn't support IPv6, will in the next release, but as the hda server and the win7 device are both behind the firewall and the firewall is set to allow traffic from the server. Now that I think of it I wonder if the requests are getting dropped because the address isn't IPv4.

#5 Updated by cpg about 11 years ago

maybe it's a good idea to separate the issues, if it's possible: dhcp vs. dns.

DNS:

the amahi /etc/named.conf configuration does listen on ::1, which, iiuc, it's the equivalent of localhost:

listen-on-v6 port 53 { ::1; };

so, it would not resolve things across the net in ipv6. perhaps you can add your ipv6 ip to that curly area, separated by a comma, and do

 service named restart

this will only last till the next time named configuration gets rewritten.
a patch for this, if it works, would need to obtain what is the ipv6 address of the HDA.

i am new to ipv6, so here is the question: given the ipv4 address (which we know), is there a way to generate the ipv6 address of the server automatically? (we could get it from the interface, however, it would be best to not do that, i guess, as it also depends on the interface.

#6 Updated by gboudreau about 11 years ago

cpg wrote:

i am new to ipv6, so here is the question: given the ipv4 address (which we know), is there a way to generate the ipv6 address of the server automatically? (we could get it from the interface, however, it would be best to not do that, i guess, as it also depends on the interface.

No, there is no correlation between the IPv4 and IPv6 addresses of an interface. They are two independent addresses which can be either set manually, or obtained through DHCP.
It's as if you'd assign two IPv4 addresses to the same interface; there's no way, knowing only one address, to 'deduce' the second address. The only way to get it is to ifconfig the interface (or equivalent).

#7 Updated by cpg about 11 years ago

the installer would have to set

IPV6INIT=yes

in the configuration of the interface.

perhaps we can set a static ipv6 ip that somehow is matched by design in some way with the ipv4 address?

#8 Updated by laz74 about 11 years ago

curly area? and which IPV6 address do you want me to add? The one that shows as the DNS server for the Win7 device or the Address of the Win7 device. I did find this about IPV6 ( http://docstore.mik.ua/orelly/networking_2ndEd/dns/ch10_15.htm) and it may be that the IPv6 field is already mis-configured? I tried removing the ::1 and replacing it with any (didn't work). I did just update the Fedora install, which had a fix for DNS, don't know what it was as it rebooted before I could check the listing.
http://docstore.mik.ua/orelly/networking_2ndEd/dns/ch10_15.htm

#9 Updated by Anonymous about 11 years ago

  • Category set to DNS

#10 Updated by bigfoot65 over 7 years ago

  • Status changed from New to Closed

No longer valid.

Also available in: Atom