Project

General

Profile

Bug #437

Gallery 2 broken for uploads

Added by cpg over 10 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
02/11/2010
Due date:
% Done:

90%


Description

from user lwhaney in the forums http://forums.amahi.org/viewtopic.php?f=13&t=1121:

Error (ERROR_COLLISION) : mkdir failed for /var/hda/web-apps/gallery2/html/g2data/albums/temp
* in modules/core/classes/GalleryAlbumItem.class at line 231 (GalleryCoreApi::error)
* in modules/core/classes/GalleryAlbumItem.class at line 154 (GalleryAlbumItem::_createDir)
* in modules/core/classes/helpers/GalleryItemHelper_advanced.class at line 234 (GalleryAlbumItem::create)
* in modules/core/classes/GalleryCoreApi.class at line 1646 (GalleryItemHelper_advanced::createAlbum)
* in modules/core/ItemAddAlbum.inc at line 80 (GalleryCoreApi::createAlbum)
* in main.php at line 250 (ItemAddAlbumController::handleRequest)
* in main.php at line 104
* in main.php at line 88

I've seen the ERROR_PLATFORM_FAILURE a few times over the past 7 days.

i can reproduce it when i try to upload a photo!

the httpd error log is:

PHP Warning:  fopen(/var/hda/web-apps/gallery2/html/g2data/locks/7): failed to open stream: No such file or directory in /var/hda/web-apps/gallery2/html/modules/core/classes/GalleryPlatform.class on line 337, referer: http://gallery2/main.php?g2_view=core.ItemAdmin&g2_subView=core.ItemAdd&g2_itemId=7


though i just noticed it's a warning, not an error.

History

#1 Updated by gboudreau over 10 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 90

There seems to be missing directories in the Gallery 2 install:

su -
cd /var/hda/web-apps/gallery2/html/g2data/
mkdir locks albums tmp
chown apache:users locks albums tmp

After that, uploading images works fine.

Whoever maintains this app should update it's install script to create those directories.

#2 Updated by bigfoot65 over 10 years ago

This has been corrected. The directories have been added to the installs script and tested. Uploaded a photo with no problems.

Recommend this bug be closed.

#3 Updated by Anonymous over 10 years ago

  • Status changed from Resolved to Closed

Per bigfoot65 app has been updated and corrected, closing

Also available in: Atom