Project

General

Profile

Bug #441

scanner server cannot see my scanner

Added by cpg over 10 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
02/16/2010
Due date:
% Done:

0%


Description

i get:

here were no scanners found on this server. Make sure the scanners are plugged in and turned on. The scanner must also be supported by SANE

the error logs show:

[Tue Feb 16 17:27:17 2010] [error] [client 192.168.32.101] /var/hda/web-apps/scanner/html/index.cgi: line 99: [: =: unary operator expected, referer: http://scanner.home.com/index.cgi?page=config
[Tue Feb 16 17:27:17 2010] [error] [client 192.168.32.101] /var/hda/web-apps/scanner/html/index.cgi: line 131: [: =: unary operator expected, referer: http://scanner.home.com/index.cgi?page=config
[Tue Feb 16 17:27:17 2010] [error] [client 192.168.32.101] /var/hda/web-apps/scanner/html/index.cgi: line 197: [: =: unary operator expected, referer: http://scanner.home.com/index.cgi?page=config
[Tue Feb 16 17:27:17 2010] [error] [client 192.168.32.101] /var/hda/web-apps/scanner/html/index.cgi: line 205: [: =: unary operator expected, referer: http://scanner.home.com/index.cgi?page=config
[Tue Feb 16 17:27:18 2010] [error] [client 192.168.32.101] /var/hda/web-apps/scanner/html/index.cgi: line 197: [: =: unary operator expected, referer: http://scanner.home.com/
[Tue Feb 16 17:27:18 2010] [error] [client 192.168.32.101] /var/hda/web-apps/scanner/html/index.cgi: line 205: [: =: unary operator expected, referer: http://scanner.home.com/
[Tue Feb 16 17:27:19 2010] [error] [client 192.168.32.101] /var/hda/web-apps/scanner/html/index.cgi: line 132: [: =: unary operator expected, referer: http://scanner.home.com/index.cgi?page=scan
[Tue Feb 16 17:27:19 2010] [error] [client 192.168.32.101] /var/hda/web-apps/scanner/html/index.cgi: line 144: [: =: unary operator expected, referer: http://scanner.home.com/index.cgi?page=scan

History

#1 Updated by cpg over 10 years ago

  • Assignee set to khelmar

#2 Updated by khelmar over 10 years ago

Those don't look like the problems... can you open a terminal window, and type

sane-find-scanner

and paste the output here? Those errors are for things where a test (i.e., if [ $ACTION = "color" ]) has $ACTION as null, so the shell has a fit. It shouldn't cause the scanner not to be found.

Also, did you run the script to set the scanner permissions? It may be that you need to use the "old" instructions in the wiki if the automatic search didn't find your scanner.

#3 Updated by cpg over 10 years ago

seems like there is something recognized, even as non-root:

[14:17:51](1)milan:~$ sane-find-scanner | grep -v ' *#'

found USB scanner (vendor=0x03f0, product=0x5d11) at libusb:002:002

[14:18:14](1)milan:~$ sudo sane-find-scanner | grep -v ' *#'

found USB scanner (vendor=0x03f0 [HP], product=0x5d11 [Photosmart C5200 series]) at libusb:002:002

[14:18:16](1)milan:~$ 

#4 Updated by bigfoot65 almost 7 years ago

  • Status changed from New to Closed
  • Assignee deleted (khelmar)

No longer valid.

Also available in: Atom