Project

General

Profile

Bug #465

installer crashes with a core dump

Added by cpg about 10 years ago. Updated about 10 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
-
Target version:
-
Start date:
03/05/2010
Due date:
% Done:

0%


Description

several people seem to be hitting this issue at the moment.
hte installer crashes with a core dump.

so far i only notice that sinatra is updated to 0.9.5 recently. but it seems to work on my system (looking to reproduce it in a VM at the moment).

http://forums.amahi.org/viewtopic.php?f=9&t=1191

the log file with the crash info is in /tmp/amahi-ruby-installer.log
please share the crash info from that file.

[root@hda ~]# /usr/share/hdactl/web-installer/install-server
== Sinatra/0.9.5 has taken the stage on 2000 for development with backup from WEBrick
[2010-03-05 16:55:19] INFO  WEBrick 1.3.1
[2010-03-05 16:55:19] INFO  ruby 1.8.6 (2009-08-04) [i386-linux]
[2010-03-05 16:55:19] INFO  WEBrick::HTTPServer#start: pid=2433 port=2000
/usr/lib/ruby/gems/1.8/gems/rack-1.1.0/lib/rack/utils.rb:283: [BUG] Segmentation fault
ruby 1.8.6 (2009-08-04) [i386-linux]

Aborted (core dumped)
[root@hda ~]#

History

#1 Updated by cpg about 10 years ago

ok, i installed sinatra 0.9.4 in two different VMs and uninstalled 0.9.5 and it does not crash with it

with 0.9.5, it crashes quickly

this is definitely sinatra related. maybe it's tripping a ruby bug or something

#2 Updated by cpg about 10 years ago

this has been traced to sinatra 0.9.5 tripping on some bug of its own or others.
we have tried it with mongrel, webrick and older versions of rack. only sinatra 0.9.4 seems to fix this issue.

here is a workaround (to be run as root):

gem install sinatra -v 0.9.4 --no-ri --no-rdoc && gem uninstall sinatra -v 0.9.5
service amahi-installer restart

then hit http://localhost:2000

#3 Updated by cpg about 10 years ago

  • Status changed from New to Resolved
  • Assignee set to cpg

seems like it's under control. released a new hdactl that force loads 0.9.4.

#4 Updated by cpg about 10 years ago

  • Status changed from Resolved to Closed

the sinatra folks have found a workaround (http://github.com/sinatra/sinatra/commit/ae34a6fde5e15e9ba3ca40cf800d0366e44eec1f) and are releasing 0.9.6 today to prevent people from hitting this issue.

our work-around seems to be working well. closing.

Also available in: Atom