Project

General

Profile

Bug #469

OpenGoo Startup Problem

Added by northridgegrp over 11 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Apps
Target version:
-
Start date:
03/06/2010
Due date:
% Done:

0%


Description

When starting OpenGoo from the Amahi Dashboard it does not launch correctly. The browser session is redirected to OpenDns for some reason. All other apps on the dashboard launch correctly.

History

#1 Updated by gboudreau over 11 years ago

This seems to work fine here.
Please create a new thread in the forums, or drop by on IRC to debug your problem.

#2 Updated by northridgegrp over 11 years ago

I should have been a little clearer. I can launch OpenGoo from the console of the server just fine. When I run it from a browser on one of the PC's on the local network it redirects to OpenDNS. It looks like a DNS resolution problem inside the Amahi server?

#3 Updated by gboudreau over 11 years ago

This is what I tried, and it worked fine.
It might be a caching problem on your client, or something similar.
Please use the support channels to get help on this.

#4 Updated by gboudreau over 11 years ago

Another user had a similar issue today. He was using Mac OS X, and it worked fine on his Windows machine.
Clearing his DNS cache fixed the problem for him.
In OS X: dscacheutil -flushcache
In Windows: ipconfig /flushdns

#5 Updated by cpg over 11 years ago

  • Status changed from New to Feedback
  • Assignee set to cpg

Is this issue fixed or worked around? nordridgegrp?

#6 Updated by cpg over 11 years ago

from nordridgegrp:

This has not been resolved. I just had a chance the other day to do flush
the DNS cache on my network clients. Well one problemo, all of my clients
are Fedora, no DNS Cache in use. I tried clearing the DNS cache on the Amahi
server problem still there. I can launch all other Amahi installed apps from
my desktops.

I did some research on webapps on apache/php sites. I am starting to think
that there might be a setup problem in a configuration file that is used to
resolve long url names that come in to the server. I am not sure where to
start looking for configuration files. Apache? PHP? OpenGoo? All three?

Like I said before I can run OpenGoo just fine from the HDA Dashboard on the
server's console. But when I launch from the Dashboard one one of the
desktops I land up on an OpenDNS search page with results trying to show
links to all sorts of OpenGoo stuff. In a prior conversation somewhere
someone mentioned some "special setups" for OpenGoo post install on Amahi?
Where are the instructions? I couldn't find anything on the wiki.

#7 Updated by cpg over 11 years ago

in your hda, can you type this:

hda-settings | egrep -i 'foffice|goo'

thanks!

#8 Updated by bigfoot65 over 11 years ago

User changed the "ROOT_URL" from "http://opengoo" to his internal URL (i.e. http://opengoo.myinternalurl). He tried it on his server console and two Fedora client computers on his network. Works now.

So it appears that it was having a problem resolving the long URL to the Amahi Server.

NOTE: This application is being renamed to Feng Office and will be upgraded to the latest version. Will have this user test and see if this problem is corrected in the new version.

#9 Updated by bigfoot65 over 7 years ago

  • Status changed from Feedback to Closed
  • Assignee deleted (cpg)

Resolved.

Also available in: Atom