Project

General

Profile

Bug #529

greyhole quits when not configured properly - better if it not did

Added by cpg almost 11 years ago. Updated almost 11 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
05/20/2010
Due date:
% Done:

0%


Description

if GH is not configured complete to get running, or improperly, it simply quits. then monit starts it up.

however, users see a red light in the servers page, which confuses people.

wrapping a loop around it to sleep (longer time?) when it cannot operate, and complaining in the log might work better.

History

#1 Updated by trucklover almost 11 years ago

Text copied from the IRC channel on this topic. My thoughts on the subject are below.

trucklover: I too think that the greyhole indicator needs to be fixed so that it has to be turned on in the shares for it to even show up in the services that's running

yeah
it's annoying
cpg
as soon as greyhole became a public beta I found that loophole and thought it was confusing to have it in there

oh i see
cpg
or even the ability to turn it on / restart it even though greyhole isn't enabled

you want it to even not be ther
cpg
I think that it shouldn't be there
just like in webmin there is a section of unused modules. I know that I don't have those installed or running. in the amahi setup it shows that it's off, as if something is wrong even though it's not

can you add that to
cpg
imo only installed services should be on that particular page, it eliminates clutter if nothing else

#2 Updated by gboudreau almost 11 years ago

As discussed by email: That's an Amahi issue, it should be fixed in Amahi... not Greyhole.

Example: Try to remove a required conf option from httpd.conf, and then try to start it. It will do the exact same thing GH does now: die, and give an error message as to why. The monit will try to restart it over and over.

Either you don't include GH in monit, or you don't start it on boot, until the user configures both the storage pool and checks at least one share. The rails code that restarts greyhole on config change is a nice place to hook this.

#3 Updated by gboudreau almost 11 years ago

  • Status changed from New to Resolved

Resolved; duplicate of another resolved bug...

Also available in: Atom