Project

General

Profile

Bug #579

reset-user-password bug?

Added by nstg8r almost 11 years ago. Updated almost 11 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
07/22/2010
Due date:
% Done:

100%


Description

Issue: Issuing the reset-user-password completes, but logging in to the Dashboard doesn't prompt for user's new password. Consequently locks user out of Dashboard.

Background:
I have been using a new install of Amahi for several days with great success. Unfortunately, I forgot my admin users password. I performed the reset-user-password command and tried to log in the dashboard but there is no prompt to create a new password. I still have access to the box through putty with the root user, as well as the dashboard with another non admin user.

The install is from the 5.4 Express CD. What can I do to help?

History

#1 Updated by cpg almost 11 years ago

an immediate work around is to run it with -u argument to make the user not an admin

/var/hda/platform/html/script/reset-user-password -u username

admin password resets are actually not done unless there are no admins in the system.

it's impossible to remove all admins with the UI, so one must use this command on at least the last admin.

fix coming up.

#2 Updated by Anonymous almost 11 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

Applied in changeset commit:"120670e5f20f4f46773023c408874942344fc4d1".

Also available in: Atom