Project

General

Profile

Bug #620

Installation of gadget fails right after creating tmp directory

Added by SolaR almost 11 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
08/25/2010
Due date:
% Done:

0%


Description

After latest git pull, checkout amahi-6-devel and db:migrate I tried to install a gadget using:

rake gadgets:install source=/root/dev/amahi/latest/amahi/platform/gadgets/gadget_last_modified_files

Output of this command:

(in /root/dev/amahi/latest/amahi/platform/platform/html)
INFO: Task: Create tmp folder: ok
INFO: Reverting:
INFO: Task: Create tmp folder is reverted.
ERROR: Installation failed.

Some investigation lets me to believe it fails in the for-loop of "def install" (line 37) in the html/lib/gadgets_widgets_lib/install/install.rb file. The Logger is executed (line 39) but after that it starts reverting (rescue part, line 48).

The problem looks like to be originating from the save_to_db command (line 40). This command tries to get some config details about the gadget from the "#{opts[:path]}/config/config.yml" file (according to html/lib/gadgets_widgets_lib/configuration.rb) if I understand everything correctly.

The config.yml file is present in the gadget/config directory and is found (otherwise it should throw an error) so by deduction my guess is it has something to do with line 7 in html/lib/gadgets_widgets_lib/configuration.rb:

self.opts = (YAML::load(ERB.new(File.read(config_path)).result)).symbolize_keys

History

#1 Updated by cpg almost 11 years ago

  • Assignee set to marek

marek, do you know why this may be happening?

#2 Updated by SolaR almost 11 years ago

I tried installing the gadget "Latest files" using the on-click install.

The onclick installer says its installed but no entries are added in the database and the gadget doesn't show up on the "add gadgets" page.

The database has no entries for a gadget and I don't have any gadgets installed.

Debug info:

./script/console
Gadget.all

gives the following after the on-click install:

Loading development environment (Rails 2.3.4)
>> Gadget.all
=> []

#3 Updated by cpg over 7 years ago

  • Project changed from 17 to platform
  • Status changed from New to Closed
  • Assignee changed from marek to cpg

Also available in: Atom