Project

General

Profile

Bug #708

kmotion installation

Added by smystaki over 10 years ago. Updated over 10 years ago.

Status:
New
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
12/24/2010
Due date:
% Done:

0%


Description

installation scrips need some corrections to work in hda.

HOWTO_INSTALL_AMAHI_MANUAL (4.76 KB) smystaki, 12/24/2010 04:05 PM

fileslist.zip (900 KB) smystaki, 01/07/2011 03:57 AM

History

#1 Updated by bigfoot65 over 10 years ago

  • Assignee set to bigfoot65

I will work the install script for this one. It may be a few days, but I think I can get it working as a one-click app.

#2 Updated by smystaki over 10 years ago

#3 Updated by bigfoot65 over 10 years ago

Will compare files to the new install on my VM. I can see already there are some files with the user name and not apache as owner. That is probably the issue. I will try to match the ownership permissions and see if that helps.

#4 Updated by smystaki over 10 years ago

normaly this user (who is the first admnin user) should be able to do that.

[smystaki@localhost ~]$ kmotion restart
Traceback (most recent call last):
File "./kmotion.py", line 137, in <module>
main()
File "./kmotion.py", line 92, in main
init_core.gen_vhost(kmotion_dir)
File "/var/hda/web-apps/kmotion/html/core/init_core.py", line 360, in gen_vhost
f_obj1 = open('%s/www/vhosts/kmotion' % kmotion_dir, 'w')
IOError: [Errno 13] Permission denied: '/var/hda/web-apps/kmotion/html/www/vhosts/kmotion'

But can not. Thats why we need to reboot in order to restart services. Nor root can run this!!

#5 Updated by bigfoot65 over 10 years ago

I did not get this during my test install. Root does not run the script to start kmotion nor the actual kmotion install_core.py. These are both run as first admin user.

Recommend you uninstall, clear the browser cache, and the /tmp/amahi-download-cache as we did before.

If that does not help, this app may not be able to be automated with Amahi. I have to do a manual restart of motion as root, and kmotion as first admin user after adding a device. Once done, then it seems to work ok. The app design is not the best for the Amahi platform. Maybe the author can assist with modifying its code to be better suited.

#6 Updated by smystaki over 10 years ago

Same behavior as yours finaly.
Requires one restart. Seems that kmotion is not starting after installation.

#7 Updated by bigfoot65 over 10 years ago

Not sure, it appears to be started, but not working as desired. I will play with it a bit more and try to fix it.

Also available in: Atom