Project

General

Profile

Bug #713

adito taking over port 80

Added by cpg almost 10 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
01/04/2011
Due date:
% Done:

0%


Description

we had a user where adito was taking over port 80 ... because somehow it was started before httpd.

this is very very bad. means it will break the amahi platform web interface.

there are two bad things going on here:

1) adito grabs port 80 unceremoniously (not sure how to configure it to NOT do that)

2) adito starts before httpd due to this line in /etc/init.d/adito

  1. chkconfig: 345 56 26

this combination is deadly after installing adito and rebooting.

best solution:

make it not take port 80, guaranteed

as a second line of defense, the init file should have priority 99 99, not 56 26
(see man chkconfig for how that works).

this init file seems to come from

install/platforms/linux/install-service

so, patching that file should do the trick, i think.

any way to fix this asap and test it with a reboot?

History

#1 Updated by bigfoot65 almost 10 years ago

Made some changes and set the priority to 99 99 as suggested. Please try the OpenVPN ALS Update app and let me know if it works. I installed on a VM, rebooted, and it was still working as designed.

I will update the live app once this has proven to fix the issue. I have implemented it on my own HDA and worked fine on restart.

#2 Updated by cpg almost 10 years ago

  • Subject changed from adito considered harmful to adito taking over port 80

i think it would be better to make the two priorities 99. from the email updates, it looks as if you are only setting the shutdown priority.

basically both of them should be high enough that it gets started before httpd and stopped before httpd.

we should keep all apps high above all basic system services. i vaguely recall the 90 range was for that.

#3 Updated by cpg almost 10 years ago

  • Status changed from Assigned to Closed

closing - all fixed

#4 Updated by ccondrup almost 10 years ago

Login to Adito webmin. Go to System Configuration > Server > Web server tab
The "HTTP Port" is default set to 80, and this of course conflicts with your HDA.

I have simply left that field blank, and this results in:
From my HDA I can go to http://adito and I am redirected to https://adito:4443 which works.
From other LAN computers if I go to http://adito I get a 404. https://adito:4443 also gives a 404.

I also set HTTP Port = 8080, and tried http://adito:8080 from LAN computer, still 404 error. On the HDA, http://adito:8080 works fine, redirects to https and displays Adito.

Adito not being accessible from LAN computers is not a problem for me, but thought it was worth mentioning.

Ping me on IRC if testing needed, nick supergreg.

#5 Updated by bigfoot65 almost 10 years ago

This has been fixed. Best way to correct it is to uninstall the app/reinstall. First, as root user do service adito stop followed by service httpd restart. Then do the app uninstall.

Also available in: Atom