Project

General

Profile

Bug #731

Feng Office doesnt install correctly

Added by basselito over 10 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Apps
Target version:
-
Start date:
01/25/2011
Due date:
% Done:

0%


Description

Problem description
Tried to install Feng Office, couldnt get it to answer on either http://foffice/ or http://foffice.home.com/. Going through the application install log (/var/log/amahi-app-installer.log) gave me that this app installer probably haven't been updated for awhile. It was referring to missing files in the installation (opengoo.tar.gz and opengoo.sql (OpenGoo was the former name of Feng Office)). I saved the corresponding foffice-filez from a previous installation and renamed these into opengoo. This made the installation go through and voila no more DNS problem.

Still got problems though. The link http://foffice.home.com/ now give me a blank page and the http://foffice/ link still give me external OpenDNS search page. There is probably something wrong with the installation still, but since Im no php coder I can't discern where the problem lies.

History

#1 Updated by basselito over 10 years ago

I am blaming the late hour for my mistake of not mentioning platform... =)

Amahi is installed on Fedora 12 according to instructions on amahi.org in a VM running under Virtualbox 3.2.12 r68302.

#2 Updated by bigfoot65 over 10 years ago

  • Assignee set to bigfoot65

This app makes use of the autoback feature. In other words, if you uninstall an older version of the app, it imports the data. To correct your issues, uninstall the app. Go to /var/hda/web-apps and remove the backup files. Typically called foffice.sql and/or foffice.tar.gz. Once complete, recommend reboot to ensure things are clean then reinstall.

This app does not work well outside the local network do to its design.

#3 Updated by basselito over 10 years ago

Did as asked, uninstalled Feng Office, removed the backup files in /var/hda/web-apps/ (foffice.sql and foffice.tar.gz), rebooted and reinstalled. From the Amahi-machine itself now both addresses work (http://foffice/ and http://foffice.home.com/), however on all other machines on my internal network the OpenDNS takes over and sends me to their search page instead. It seems as though foffice isnt correctly updating the Amahi DNS database.

I am no DNS expert by any means and I'm not familiar with the Named package... I looked into /var/named/dynamic/hda-n2a.conf and the record for foffice looks the same as other apps that I can reach both on the amahi server as from other computers in my network (foffice A xxx.xxx.xxx.xxx). Is there another place info concerning foffice needs to go???

#4 Updated by cpg over 10 years ago

  • Status changed from New to Feedback

this is almost certainly due to the clients not using your amahi HDA for their DNS.

some client computers use "corporate" settings and override hard what domain they use, so when something is accessed without domain, they force-append the corporate domain which does not work locally, then they "move up" the hierarchy and they do go to opendns, which of course takes you to their guide, etc.

this typically happens if the client computer has a corporate VPN installed or has been setup by corporate IT people.

#5 Updated by basselito over 10 years ago

Every computer that try to access Feng Office got as first nameserver in resolv.conf the IP address to the Amahi server. Also there is no problem accessing http://joomla/, http://joomla.home.com/, http://drupal/, http://drupal.home.com/ (and EVERY other application installed from the Amahi dashboard). The only one not working in this LAN is Feng Office. Still, there is nothing wrong with the application itself, it works locally on the Amahi machine. But Named doesn't work for Feng Office.

Tried this with Ubuntu 9.04, 9.10, 10.04, Fedora 14, PC Linux OS, FreeBSD 8.1, OpenSolaris 2010.1, Windows Vista (Amahi as only DNS server), Windows XP (Amahi as only DNS server). Everytime same result, all applications work except for Feng Office.

No VPN tunnels active at the time of testing.

Perhaps this issue should be recategorized as a DNS issue instead of an App issue... what do you think?

#6 Updated by cpg over 10 years ago

Interesting. However, even having a VPN installed mucks around with DNS domains, etc. Not necessary to have a VPN active or even running but disconnected.

i wonder if it's an internal setting of the app?
is there a setting in feng office that dictates what it's domain should be or something?

you can try like this from a client:

wget http://foffice/

perhaps it sends a redirect?

#7 Updated by bigfoot65 over 10 years ago

I have checked this app and see no issues. Has anyone else had problems?

#8 Updated by bigfoot65 over 7 years ago

  • Status changed from Feedback to Closed
  • Assignee deleted (bigfoot65)

No feedback indicates resolution.

Also available in: Atom