Project

General

Profile

Bug #799

Nautilus/Samba & GUI freeze and kernel panic when going to local mounted share while/after copying

Added by ccondrup over 10 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
03/30/2011
Due date:
% Done:

0%


Description

It seems I am able to reproduce this again and again.

Keyword version:
F14. Greyhole w/ MySQL. Dual pane view in Nautilus on the HDA. Drag'n'drop to copy, then try to go to /mnt/samba/ = freeze. First that pane, then that window (both panes), then the whole hda, cursor disappears etc.

Verbose:
My HDA is new, I am just starting out. Chose F14 and Greyhole with MySQL. I am currently in the process of copying data from old ntfs drives (they are also in the HDA but mounted manually) to the locally mounted samba shares to get the data into the Greyhole pool of ext3 drives. (When the data is in GH (and CrashPlan) I will format the ntfs drives and make them part of the GH pool)

Steps to reproduce:
1. Power up the hda, login
2. Mount my ntfs drive as /media/media/ (yes that was its name)
3. Point Nautilus to /media/media/series/
4. Hit F3 to get the extra Nautilus pane, switch one pane to /mnt/samba/Series/ (followed wiki for mount shares locally)
5. Drag and drop some files (I tried both pictures, tv-episodes, installation files ... from 2GB to 80GB operations)
6. During or after this copy to smb, navigate one folder up in the Nautilus pane to go to /mnt/samba/ - this immediately results in a "thinking"/loading cursor.. the pane is then shown without contents and appears to load without progress for a couple of minutes then the whole GUI freezes. If I try to System>Shutdown before the GUI freeze, I sometimes get a kernel panic. I usually tail the GH log in a terminal so I have been able to see the computer still churning away at GH tasks even though the first Nautilus pane has already stopped responding. I eventually have to hard reboot, and as a [natural] result have noticed a couple of null-byte files in the samba shares upon relogin.

My fstab: http://fpaste.org/aovH/
If you need HW-info or similar, you will need to instruct me how to get it, I am learning Linux as I go here. I believe I also have managed to get a couple of screens if my description was too vague.
You can usually reach me on irc, nick supergreg. Timezone GMT+1.

messages.zip (155 KB) ccondrup, 03/31/2011 03:11 PM

History

#1 Updated by ccondrup over 10 years ago

Follow-up:
After getting out of bed today I notice the copying of a lot of image files is done and Greyhole is done clearing the LZ a few hours ago.

I then close Nautilus, go to Places and choose my bookmark which points to /mnt/samba/ in a fresh Nautilus window. It worked very slow again, but managed to display 3 folders before the gui froze. They were Books (0 items), Movies (1 item), Pictures (1 item). The other shares that actually have a lot of folders/files were not displayed (at least not before gui freeze)

#2 Updated by cpg over 10 years ago

It would be interesting to see the kernel panic details (what process caused it, etc.). The file

/var/log/messages

may still have the details of the panic. Can you take a look?

#3 Updated by ccondrup over 10 years ago

grep'ed for "panic" in /var/log/ but only got some stuff regarding zombie panic, hehe.

I then scrolled through /var/log/messages and suddenly got the dreaded "DOH, PEBKAC"-feeling when I saw lines mentioning unable to find the mount point /media/install for share "meh". This "meh" was a temp hda-share I setup just to pull some data from one of the ntfs drives onto another client before formatting it... it was meant to be temp and I have obviously forgotten to delete the share in amahi, so it is correct that it didn't exist after booting (since the drive wasn't mounted any longer after booting). That very well might be why Samba freezes, I don't know.. but for such a mistake to cause the entire gui to freeze/crash seems a bit drastic.

I'll just attach the messages file, since I really don't know where to draw the line for which log lines you need or not. FYI, there are also more messages-files (archives?) which have dated postfix.


Edit: Another update:
I deleted the "meh" share from hda. Then tried to show /mnt/samba/ in file explorer, it froze up. Chose System > Shutdown. Got a popup saying "File Explorer is not responding", chose "reboot anyway". GUI shuts down, it starts to kill processes. As always they all read OK in green except for Amahi-installer which reads NOT OK in red. Then I spotted a stack trace, managed to write this down:
Shutting down SMB services: [OK]
[33920.578003] Process smbd (pid: 13530, ti=dad9c000 task=ecf3bf20 task.ti=dad9c000)
Stack:
Call Trace:
Code: 99 c0 e8 .. (bunch of hex didn't have time to write down the rest, it scrolls on with more pids+traces)

#4 Updated by ccondrup over 10 years ago

No cigar, this has just happened again, and this time I have neither copied anything nor does a share with invalid mount point exist.

Here's what I did today:
1. Power up hda.
2. Check greyhole log, it said "sleeping"
3. Check LZ/root free space: 35GB
4. Open Nautilus dual pane. Left pane: /mnt/samba/Movies/. Right: /media/media/movies/.
5. Confirm folders are in sync, decide to copy something else. Left pane: Navigate to /mnt/samba/
6. Behold Samba freeze up again, close the Nautilus window, confirm other windows are still working.
7. Open another Nautilus window but not navigate to /mnt/samba/
8. Wait a couple of minutes, behold the whole GUI freeze
9. From client computer, behold the hda irc client time out with message "Ping timeout: 240 seconds"
10. Reboot hda, inspect /var/log/messages. Result: http://fpaste.org/RngX/

What do the CIFS VFS errors indicate?

#5 Updated by cpg over 10 years ago

this sort of thing could be related to memory or cpu power management.

how was this machine put together? did you do it or was it a stock machine?

can you share this?

fpaste /proc/acpi/processor/CPU*/power

#6 Updated by ccondrup over 10 years ago

This is an old workstation which was not a stock one, but has been running fine for 3-4 years.
Output is http://fpaste.org/F1p4/

Bigfoot said it might be due to bad sectors on disk, so am currently running e2fsck
It has finished checking the first one, results:
[root@amahi cc]# e2fsck -c /dev/sdc1
e2fsck 1.41.12 (17-May-2010)
Checking for bad blocks (read-only test): done
d5: Updating bad block inode.
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
d5: * FILE SYSTEM WAS MODIFIED *
d5: 466575/15269888 files (4.8% non-contiguous), 6446767/61049344 blocks

.. can I continue using a disk which has bad sectors? Somehow tell it to just avoid those sectors? I guess I'll man e2fsck some more.

#7 Updated by ccondrup over 10 years ago

Two disks had some sectors which were added to the bad block inode. That still didn't stop my freezes, though.

So, I switched to using two Nautilus windows, and instead of navigating back and forth in the /mnt/samba/ one, I've been using the "list" view which lets you expand contents of folders directly as a hierarchy tree - this actually works very well. Now I'm able to copy files to subfolders of the different shares under /mnt/samba/ and navigate these subfolders without it freezing up.

It's a workaround for me for the moment, but I would really like to get to the bottom of the real issue here.

#8 Updated by bigfoot65 over 7 years ago

  • Status changed from New to Closed

No longer needed.

Also available in: Atom