Project

General

Profile

Bug #801

Application Error Rails application failed to start properly

Added by iluciv about 10 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
04/01/2011
Due date:
% Done:

0%


Description

Hi I have this when trying to connect to my HDA through a web browser. I can restart the server and it will work for a period of time but will then fail and I'll get this error on the http://hda page.

I have fedora 14 amahi 6 install and only a couple of applications installed.

I have my / directory as a xfs file system my /boot is ext4 and I don't have lvm enabled.

I have two drives an IDE and a sata2 drive

Applications I have installed are

The grey theme
recipe app
speedtest
about two others but I can't access it to see atm will reboot server an update ticket later. Though it has been doing it before I installed apps.

I have yum updated

The server is running as my dhcp and dns (secondary dns) google (8.8..8.8) is my primary on my router.

Happy to provide any further info required I was just going to reinstall this weekend but was asked to provide production.log so have attached in ticket.

production.log View (48.8 KB) iluciv, 04/01/2011 08:13 PM

History

#1 Updated by cpg about 10 years ago

Your production.log file ( in /var/hda/platform/html/log/ for others watching) does not have errors, so we can't debug from it.

Ideally, we need that file immediately (or very soon) after an error is observed.

#2 Updated by dr2chase about 10 years ago

For reasons that are surely unrelated, I get that same error message, and I wish to suggest that it is a poorly constructed error message. You could save the first step in the bug reporting if the error message included references to log files that an admin should check (spewing contents of log files to the browser is a security risk, of course).

My situation is that I am attempting to also run Trac (I have done this before, under both MacOS and Solaris), and (as is usually the case) I have made some mistake. However, this error, allegedly from Rails, is useless, and all the log files I know to look at, look fine to me. It is not productivity-enhancing if I have to file bug reports to get access to this information. If I should RTFM, include a hyperlink to the M -- there are many, many manuals.

#3 Updated by cpg about 10 years ago

This error also peeves us.
No user should ever see this.

This error shows some fundamental issue where the basics of the stack cannot be even started.

#4 Updated by nagybal over 7 years ago

  • Assignee set to cpg

I just installed Amahi 7.1 Express DVD install. Did not mess around any command line stuff on purpose.

Downloaded the Transmission App using the amahi-app-service. If the HDA restart the transmission service is unavailable. I need to access the amahi dashboard and restart the "Transmission Server". If I do I get this same error.

#5 Updated by bigfoot65 over 7 years ago

  • Status changed from New to Closed
  • Assignee deleted (cpg)

Sounds like a potentially corrupt install.

Please open a new bug with details. This one is for a completely different OS and Amahi platform.

Add any log files as well.

Also available in: Atom