Project

General

Profile

Bug #805

Drive Space is not showing accurately

Added by jfulcher over 9 years ago. Updated about 9 years ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
setup-storage
Target version:
-
Start date:
04/13/2011
Due date:
% Done:

0%


Description

If I go to http://hda/setup?sub=partitions&tab=storage the drives I have mounted under / and /var/hda/files show correctly. All the other mounts show as 0 bytes and have a :-( next to them.

I have 9 total drives - 6 internal all EXT4 and 3 external that are NTFS-3G.

http://fpaste.org/Cabq/ - is a paste of my sysinfo.

History

#1 Updated by jfulcher about 9 years ago

jfulcher wrote:

If I go to http://hda/setup?sub=partitions&tab=storage the drives I have mounted under / and /var/hda/files show correctly. All the other mounts show as 0 bytes and have a :-( next to them.

I have 9 total drives - 6 internal all EXT4 and 3 external that are NTFS-3G.

http://fpaste.org/Cabq/ - is a paste of my sysinfo.

Also I found some further information in the amahi log that might point to the issue:

Processing SetupController#index (for 192.168.1.110 at 2011-06-23 08:58:01) [GET]
Parameters: {"sub"=>"partitions", "action"=>"index", "controller"=>"setup", "tab"=>"storage"}
  • disk stats error for /var/hda/files/movies: #<Errno::EACCES: Permission denied>
  • disk stats error for /var/hda/files/movies/dvd: #<Errno::EACCES: Permission denied>
  • disk stats error for /var/hda/files/tv: #<Errno::EACCES: Permission denied>
  • disk stats error for /var/hda/files/music: #<Errno::EACCES: Permission denied>
  • disk stats error for /var/hda/files/movies/bluray1: #<Errno::EACCES: Permission denied>
  • disk stats error for /var/hda/files/movies/bluray2: #<Errno::EACCES: Permission denied>
  • disk stats error for /var/hda/files/movies/bluray3: #<Errno::EACCES: Permission denied>
    Rendering template within layouts/amahi
    Rendering setup/index
    Completed in 2884ms (View: 49, DB: 99) | 200 OK [http://hda/setup?sub=partitions&tab=storage]

#2 Updated by jfulcher about 9 years ago

  • Category set to setup-storage

#3 Updated by cpg about 9 years ago

aha, that is in fact interesting. the mounts are not checkable due to a permissions error.

would love to see those permissions. canyou do a few of these in the relevant paths?

cd /somewhere; ls -l | fpaste

#4 Updated by jfulcher about 9 years ago

http://fpaste.org/FjHC/

That's the most appropriate folder as it has several folders that are mount points under it.

#5 Updated by cpg about 9 years ago

the blueray mounts are fuseblk, which means they are probably only accessible to any other user other than the one that mounted it. hence the error. not clear what process mounted it, but probably root or the user connected to the console.

there probably are some options in fuse to make these word readable and writeable, but i don't know them off hand.

the dvd one is actually mounted with some funky permissions. can you change them to, say 755 ?

#6 Updated by jfulcher about 9 years ago

jfulcher wrote:

If I go to http://hda/setup?sub=partitions&tab=storage the drives I have mounted under / and /var/hda/files show correctly. All the other mounts show as 0 bytes and have a :-( next to them.

I have 9 total drives - 6 internal all EXT4 and 3 external that are NTFS-3G.

http://fpaste.org/Cabq/ - is a paste of my sysinfo.

Tried 755 with the same results on dvd. made sure the other mount points were 755 too. They are all owned by dev.users - I tried changing to dev.dev as well with no help. dev is also the user that is logging into the web interface, but not sure if that makes any difference

#7 Updated by cpg about 9 years ago

fuse is notoriously hard in terms of permissions.

e.g. mounting a directory as a user, say with sshfs, does not allow even root to see the mounted area.

So I would not expect the ntfs stuff to be seen at all by the apache user (that's the one running the web server).

As for the dvd one .. are you still seeing the errors in the log for it?

#8 Updated by jfulcher about 9 years ago

Yeah still have the errors

Processing SetupController#index (for 192.168.1.107 at 2011-06-24 16:21:19) [GET]
Parameters: {"sub"=>"partitions", "action"=>"index", "controller"=>"setup", "tab"=>"storage"}
  • disk stats error for /var/hda/files/movies: #<Errno::EACCES: Permission denied>
  • disk stats error for /var/hda/files/movies/dvd: #<Errno::EACCES: Permission denied>
  • disk stats error for /var/hda/files/tv: #<Errno::EACCES: Permission denied>
  • disk stats error for /var/hda/files/music: #<Errno::EACCES: Permission denied>
  • disk stats error for /var/hda/files/movies/bluray1: #<Errno::EACCES: Permission denied>
  • disk stats error for /var/hda/files/movies/bluray2: #<Errno::EACCES: Permission denied>
  • disk stats error for /var/hda/files/movies/bluray3: #<Errno::EACCES: Permission denied>
    Rendering template within layouts/amahi
    Rendering setup/index
    Completed in 1743ms (View: 23, DB: 47) | 200 OK [http://hda/setup?sub=partitions&tab=storage]

Also available in: Atom