Project

General

Profile

Bug #809

MediaTomb - Debian

Added by bsk over 9 years ago. Updated about 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Apps
Target version:
-
Start date:
04/14/2011
Due date:
% Done:

100%


Description

Here are the outputs of the install and logs for MediaTomb on Debian

amahi-app-installer.log > http://paste.debian.net/114060/
access_log > http://paste.debian.net/114057/
error_log > http://paste.debian.net/114056/
ls -l of /var/hda/web-apps/mediatomb/html/ > total 0

I get a 503 error on http://mediatomb

History

#1 Updated by cpg over 9 years ago

none of the pastes work for me.

paste.amahi.org is decomissioned and the others seem to not resolve dns.

sigh.

#2 Updated by bsk over 9 years ago

WOOPS, doing this from vm to local, changed them.

#3 Updated by eFfeM over 9 years ago

The strange/interesting thing is that the app-installer log does not seem to install mediatomb itself
bsk can you check if nslookup mediatomb works ? If that works dns is ok the app is only partially installed
Otherwise can't say too much about it as I have no clue what script/commands are executed that produce app-installer.log

#4 Updated by Lincee over 9 years ago

perhaps this clarifies things:

sudo: no tty present and no askpass program specified

This error message will occur if sudo is not able to ask for the password (no tty is present) (like for instance when trying to sudo rsync).

One solution to this is to add the line “Defaults visiblepw” to the /etc/sudoers file.

[Todd C. Miller Todd.Miller at courtesan.com said on sudo-users: Recent versions of sudo will refuse to prompt for a password if no tty is present, since it is not possible to turn off echo in this case. You can restore the old behavior with a line like above]

#5 Updated by SolaR about 9 years ago

Temporarily changed the install script to install the deb's as the RPM field isnt ready yet to support deb-packages.

The sudo problem is caused by some problem with the sudoers file.
It's under investigation.

#6 Updated by SolaR about 9 years ago

Ok, problem is with the sudoers file.
The specific amahi sudoers file ( /etc/sudoers.d/amahi ) should be changed to the following:


# Amahi related privileges

User_Alias      HDAUSER = www-data
Cmnd_Alias      HDAWEBAPPS = /var/hda/web-apps/*/elevated/,/var/hda/apps/*/elevated/,/var/hda/elevated
Defaults:HDAUSER       !requiretty
HDAUSER         ALL = NOPASSWD: HDAWEBAPPS

This should also fix all other sudo problems.

#7 Updated by bsk about 9 years ago

  • Status changed from Assigned to Resolved

#8 Updated by bsk about 9 years ago

  • % Done changed from 0 to 100

#9 Updated by bsk about 9 years ago

  • Status changed from Resolved to Closed

Also available in: Atom