Project

General

Profile

Bug #812

Network Initialization Fails During Amahi Install

Added by bsk over 9 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Urgent
Assignee:
Category:
hda-install
Target version:
-
Start date:
04/17/2011
Due date:
% Done:

100%


Description

Network initialzation fails during install of Amahi at 42%, the following logs and info are listed below.

Before Amahi

Output of --sysinfo: http://fpaste.org/OpL3/
Output of ifconfig: http://fpaste.org/9fWQ/
Output of route -n: http://fpaste.org/KSqX/
Output of ifcfg-eth0: http://fpaste.org/vMoT/

After Amahi

Output of hda-install log: http://fpaste.org/f6HH/
Output of --sysinfo: http://fpaste.org/bJFm/
Output of ifconfig: http://fpaste.org/2FQR/
Output of route -n: http://fpaste.org/aZ2a/
Output of ifcfg-eth0: http://fpaste.org/z7eo/

Correect ifcfg-eth0: http://fpaste.org/maPR/

log.txt View (23.8 KB) smccloud, 04/21/2011 11:11 AM


Related issues

Related to platform - Bug #813: hdactl is not creating a working ifcfg-eth0 file Closed 04/18/2011

History

#1 Updated by cpg over 9 years ago

the symptom is that hda_production is created, however, it has NO tables in it:

echo show tables | mysql -u root -phda hda_production

tables are not created prolly due to rails (and pluginfactory) not being installed properly or at all.

rails/pf may be missing due to a lack of network connectivity.

the core of this issue is lack of network connectivity to continue the install.

the erroneous ifcfg-eth0 is really a bug in hdactl, where hdactl SHOULD NEVER EVER generate something with garbage. even if it's called and started, and it might look like hda_production is there, it should CHECK that the DB returns something meaningful. granted that's rare, but it's always the case in this situation.
(BK, could you file a separate bug for this one?)

now ..

why is there network connectivity lost even before rails comes into play??
i'd suspect that NetworkManager.

it could be that the installer is doing something like tickling some setting somewhere that trips Network Manager and it goes bezerk. one possibility is that the installer unisntalls NetworkManager and it now (sometimes?????) turns off networking?

#2 Updated by cpg over 9 years ago

  • Assignee changed from cpg to eFfeM

sending to effem while i am travelling in case he has some ideas.
(i am out of pocket for 24/48 hours - effem don't feel too obligated - just trying to see if there is an idea you can bring in here)

#3 Updated by eFfeM over 9 years ago

  • Assignee changed from eFfeM to cpg

Well the pasties are expired or about to expire. Better put stuff in a log file and attach that to the bug report.

I've seen this behaviour in one situation:
if hdactl was installed under debian the hdactl daemon starts automatically. This happens before the actual hda-install is done.
In that case what happened was that hdactl tried to query the db and did not get the proper values and went on using the empty/uninitialized values it received.

This is similar to the analysis of cpg.

Possible solutions:
  • avoid that hdactl is started before the database is filled. That is what I did for debian in http://git.amahi.org/?p=amahi.git;a=commit;h=51ba3875a37ea738ccfc569ef8158ba8abd6c5a1
    For debian I did it in the init script but it is probably better to do it in hdactl itself when it starts.
  • within hdactl check for meaningful values (which is a good idea anyway)
  • when starting hda-install make sure that the hdactl service is stopped.

Best solution is to implement all three of these as they are all three faulty situations (and some may happen in other places as well.

#4 Updated by bsk over 9 years ago

A current workaround to this would be to get network back, install rails 2.3.4 and pluginfactory then run hda-install CODE

Edit /etc/sysconfig/networking/devices/ifcfg-eth0 with correct information.

Do a service network restart

Install Rails 2.3.4 gem install --no-ri --no-rdoc rails -v 2.3.4

Install PluginFactory gem install --no-ri --no-rdoc pluginfactory

Then run the installer again hda-install CODE

#5 Updated by cpg over 9 years ago

yes, the bug for hdactl is #813 (thanks bk!)

i am not sure quitting hdactl is a good idea, reliability wise (based on experience).
we need to try really hard not to quit. e.g. stay sleeping, then trying 5 minutes later.

#6 Updated by cpg over 9 years ago

possible fix at

http://alpha.amahi.org/tmp/hdactl-4.1.1-1.i686.rpm
http://alpha.amahi.org/tmp/hdactl-4.1.1-1.x86_64.rpm

(32bits and 64 bits)

install with

rpm -Uvh http://alpha ...
killall -9 hdactl

immediately before running the amahi installer (i.e. after entering the desktop for the first time but before installing amahi)

#7 Updated by smccloud over 9 years ago

Appears to install fine, however when you try to go online after rebooting DNS is not working. I fixed it by telling the HDA to use our domain DNS servers (HDA is at work).

#8 Updated by cpg over 9 years ago

ok, we found a bug in the rpms i posted and it has been corrected. same RPM paths.

looks solid now ... please test.

#9 Updated by cpg over 9 years ago

allright - the bits have been release out to the repos.

please reinstall and update this bug indicating how it went!

#10 Updated by Anonymous over 9 years ago

  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

Applied in changeset commit:"2b65101d266af708a8318a923db87f73c7cdbc33".

#11 Updated by bsk over 9 years ago

  • Status changed from Closed to Resolved

#12 Updated by Anonymous over 9 years ago

  • Status changed from Resolved to Closed

Applied in changeset commit:"d896d1ae60169ec489cf7286f42de139ae4f03cf".

Also available in: Atom