Project

General

Profile

Bug #821

Amahi problems after installation on ubuntu 10.04 32-bit

Added by SolaR almost 10 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
platform
Target version:
-
Start date:
04/30/2011
Due date:
% Done:

0%


Description

I installed Amahi on ubuntu server 10.04 32-bit (minimal virtual install <- very small footprint) and the install went ok.

After install i ran into some problems:
- After the reboot the ip address which was set during install wasn't applied. Had to do a networking restart. After that, it had the ip address it should've had.

- It looks like the DHCP server bit isn't working right (after disabling the routers DHCP server). I get fail messages when i try to start it and it reports that the config file isn't right.

- In the HDA webUI, the servers tab is giving an application error. I can't see which servers are running.
output:

Processing SetupController#index (for 192.168.81.1 at 2011-05-01 00:53:39) [GET]
  Parameters: {"sub"=>"servers", "action"=>"index", "controller"=>"setup", "tab"=>"setting"}

TypeError (can't convert Symbol into String):
  app/models/server.rb:111:in `join'
  app/models/server.rb:111:in `pid_file'
  app/models/server.rb:133:in `cmd_file'
  app/models/server.rb:141:in `monit_file_add'
  app/models/server.rb:177:in `create_hook'
  app/models/server.rb:38:in `create_default_servers'
  app/controllers/setup_controller.rb:123:in `index'
  /usr/lib/ruby/1.8/phusion_passenger/rack/request_handler.rb:92:in `process_request'
  /usr/lib/ruby/1.8/phusion_passenger/abstract_request_handler.rb:207:in `main_loop'
  /usr/lib/ruby/1.8/phusion_passenger/railz/application_spawner.rb:418:in `start_request_handler'
  /usr/lib/ruby/1.8/phusion_passenger/railz/application_spawner.rb:358:in `handle_spawn_application'
  /usr/lib/ruby/1.8/phusion_passenger/utils.rb:184:in `safe_fork'
  /usr/lib/ruby/1.8/phusion_passenger/railz/application_spawner.rb:354:in `handle_spawn_application'
  /usr/lib/ruby/1.8/phusion_passenger/abstract_server.rb:352:in `__send__'
  /usr/lib/ruby/1.8/phusion_passenger/abstract_server.rb:352:in `main_loop'
  /usr/lib/ruby/1.8/phusion_passenger/abstract_server.rb:196:in `start_synchronously'
  /usr/lib/ruby/1.8/phusion_passenger/abstract_server.rb:163:in `start'
  /usr/lib/ruby/1.8/phusion_passenger/railz/application_spawner.rb:213:in `start'
  /usr/lib/ruby/1.8/phusion_passenger/spawn_manager.rb:262:in `spawn_rails_application'
  /usr/lib/ruby/1.8/phusion_passenger/abstract_server_collection.rb:126:in `lookup_or_add'
  /usr/lib/ruby/1.8/phusion_passenger/spawn_manager.rb:256:in `spawn_rails_application'
  /usr/lib/ruby/1.8/phusion_passenger/abstract_server_collection.rb:80:in `synchronize'
  /usr/lib/ruby/1.8/phusion_passenger/abstract_server_collection.rb:79:in `synchronize'
  /usr/lib/ruby/1.8/phusion_passenger/spawn_manager.rb:255:in `spawn_rails_application'
  /usr/lib/ruby/1.8/phusion_passenger/spawn_manager.rb:154:in `spawn_application'
  /usr/lib/ruby/1.8/phusion_passenger/spawn_manager.rb:287:in `handle_spawn_application'
  /usr/lib/ruby/1.8/phusion_passenger/abstract_server.rb:352:in `__send__'
  /usr/lib/ruby/1.8/phusion_passenger/abstract_server.rb:352:in `main_loop'
  /usr/lib/ruby/1.8/phusion_passenger/abstract_server.rb:196:in `start_synchronously'
  /usr/lib/phusion_passenger/passenger-spawn-server:61

Rendering /var/hda/platform/html/public/500.html (500 Internal Server Error)

- In the HDA webUI, on the settings tab in the System info box:
- System not giving correct info
- Platform is empty
- Core is empty

- In the HDA webUI, on the storage tab, the partitions are shown but there are no disks reported.

History

#1 Updated by eFfeM almost 10 years ago

Next time please report one problem per bug, that makes it simpler to track if only some things are solved.

Wrt the networking patch: this used to be there in an older version, it should be gone now (can't reproduce it)

Wrt the ruby error: this one is fixed, patch submitted to cpg

Wrt dhcp: fixed, patches submitted to cpg

webui settings and disks are still under investigation

#2 Updated by eFfeM almost 10 years ago

setings: platform and core: these are set in setup-controller.rb, the test for the version number used rpm, added a conditional to test for fedora or not and if not use apt-cache
submitted to cpg

#3 Updated by eFfeM almost 10 years ago

the unknown part in System is caused by uname -i returning "unknown" under debian. This is behaviour that is allowed according to the man page of uname.
uname -m always work, authored patch ot use that (it gives some more detail too; -i returns i368, -m returns i686 (which is more appropriate)
patch submitted

missing disk info is under investigation

#4 Updated by eFfeM almost 10 years ago

the missing disk info is because the hddtemp service is not running. Still investigating why it does not; probably a config issue

#5 Updated by bigfoot65 almost 9 years ago

  • Status changed from New to Closed

Closing as this version is no longer supported.

#6 Updated by eFfeM almost 9 years ago

if I recall correctly the hddtemp issue is still there in 12.04
(in a vm it is quite visible as hddtemp cannot really determine the temperature of a virtual disk).
Guess there should be a new bug for 12.04 relating to this (and the solution is probably to reconsider if and how to use hddtemp)

Also available in: Atom