Project

General

Profile

Bug #927

Ubuntu Shares Permissions

Added by bigfoot65 over 8 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
ubuntu
Target version:
-
Start date:
06/24/2012
Due date:
% Done:

100%


Description

Seems when creating shares, they are owned by 500:users instead of the firstadmin:users. This was a 64-bit install.


Related issues

Related to ubuntu - Bug #957: Dashboard User Creation Closed 08/05/2012

History

#1 Updated by bigfoot65 over 8 years ago

  • Priority changed from Normal to Medium

It appears that shares are owned by the Ubuntu equivalent of apache:users. I changed the ownership of /var/hda/files to my first user:users and it was changed back to apache:users within a day.

Not sure what is making the change, but presume it's Samba related. This prevents writing to shares in my case using a third party sync tool.

#2 Updated by guerilla over 8 years ago

Had the same problem, resulting in an inability to create files/folders in anything under /mnt/samba/*.

After discussion on irc this was resolved by running these commands as root

chown -R myuser:users /var/hda/files
chmod -R g+w /var/hda/files

where myuser is the original user name set when installing amahi.

#3 Updated by cpg over 8 years ago

  • Status changed from New to Assigned
  • Assignee set to eFfeM

i wonder if updates are the reason these permissions get reverted somehow.
effem, can you take a look?

#4 Updated by cpg over 8 years ago

  • Assignee changed from eFfeM to cpg
  • Priority changed from Medium to High

confirmed that an update of hda-platform blows away the permissions in /var/hda/files. pretty serious.

#5 Updated by bigfoot65 over 8 years ago

This is a problem when creating shares as well. Each new share does not have the correct permissions. This is a dual problem it seems. Amahi updates changes the ownwership and so does the actual share creation via the dashboard.

#6 Updated by Anonymous about 8 years ago

  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

Applied in changeset commit:3a0010e7a92f832785450090bf105d583daeaa3f.

#7 Updated by guerilla about 8 years ago

this may be a silly question but how do i apply this update?

#8 Updated by bigfoot65 about 8 years ago

See the forum post about testing:

http://forums.amahi.org/viewtopic.php?f=42&t=4273

Once it is validated, there should be a patch pushed automatically.

#9 Updated by cpg about 8 years ago

  • Category set to ubuntu
  • Status changed from Closed to Assigned

#10 Updated by Anonymous about 8 years ago

  • Status changed from Assigned to Closed

Applied in changeset commit:d7a6de8c480cb61725d4ed7b0bd6131f068ad987.

Also available in: Atom