Project

General

Profile

Bug #935

sabnzbd install fails

Added by derMerl over 8 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
hdactl/installer
Target version:
-
Start date:
07/03/2012
Due date:
% Done:

0%


Description

sabnzbd install fails.

logfile looks like this:
http://pastebin.com/y7wcPJDC

56.png View (26.6 KB) guerilla, 07/04/2012 09:01 AM

History

#1 Updated by guerilla over 8 years ago

Same problem, my log here if that helps

http://paste.ubuntu.com/1073837/

#2 Updated by bigfoot65 over 8 years ago

This appears to be a connectivity/install script time out issue. Do either of you have slow connections? Please try again after a rebooting the HDA. Ensure there is no activity other than the install going on, i.e. not downloads in progress, etc.

#3 Updated by guerilla over 8 years ago

I have a fibre optic connection and have never had problems with timing out before.

I have just rebooted and tried to install the app again. the relevant lines are

======= app install begin @ Wed Jul 04 15:53:01 +0100 2012 ==========
Installing app id l87u14kg9n under /var/hda/platform/html ENV=production

I have left the hda page open, currently it is stuck on preparing to install.

#4 Updated by bigfoot65 over 8 years ago

This app installs from the Ubuntu repo, so there may be some issue on their end. I have tested a several times in a VM and cannot duplicate.

Have you installed Ubuntu updates? Also, before trying the app again, can you do sudo apt-get update? Then reboot the box and try the install. Curious to see if this changes anything. It's a shot in the dark at the moment trying to determine what is going on.

#5 Updated by bigfoot65 over 8 years ago

I stand corrected, I just now was able to duplicate the issue. Looking for a potential solution now. I have a test app that uses the source like the Fedora edition if you would like to test and report back. I have given you access.

#6 Updated by guerilla over 8 years ago

tried the above.

======= app install begin @ Wed Jul 04 16:28:28 +0100 2012 ==========
Installing app id l87u14kg9n under /var/hda/platform/html ENV=production

After installing Ubuntu serve but before installing amahi I think (read pretty sure) I ran sudo apt-get upgrade could this be causing the problem?

Is the source version the same as http://www.amahi.org/apps/sabnzbd ? As I have access to that already.

Just to clarify I am trying to install this http://www.amahi.org/apps/sabnzbd-plus

I have time to test but limited knowledge, is this best discussed on irc?

#7 Updated by bigfoot65 over 8 years ago

Ok, doing upgrade will add all the updates to Ubuntu. Doing update refreshes the repo. As for which app to try, the one I want you to test is: SABnzbd+ Update Test

http://www.amahi.org/apps/sabnzbd-update-test

It uses the source instead of a DEB from the Ubuntu repo. It appears to work, so if I can ensure its fairly stable I can update the current SABnzbdPlus app to use it vs the DEB. The ones you mentioned are not the one I want you to test. The test app should be free as far as I know.

#8 Updated by guerilla over 8 years ago

installation of the new app went fine. The web app seems to be continually loading now though.

service sabnzdbplus status

  • SABnzbd+ binary newsgrabber: not running

#9 Updated by guerilla over 8 years ago

cntrl + shift + F5 fixed loading issue. still confused about the service though.

#10 Updated by bigfoot65 over 8 years ago

Yes, it can be restarted and stopped, but the pid is not being correctly created by the init script.

I am still trying to figure that out, but the app does work. No need to do manual service calls as the app can do restart, start, and shutdown from the browser. Not to start it obviously this would require CLI.

This app has and probably will always be brittle. Don't know why it has to be so difficult, but finding a good init script is hard to do.

#11 Updated by guerilla over 8 years ago

Okay, its not a problem for me to restart from web interface, i don't think i started it from the CLI once previously. Shall I just run it as normal now and report any further problems?

#12 Updated by bigfoot65 over 8 years ago

I am going to update the live app shortly. Then if you would uninstall this one, reboot and try the live app that would be great.

#13 Updated by guerilla over 8 years ago

If you let me know when, I will.

#14 Updated by bigfoot65 over 8 years ago

Still having issues with the service. For now, stay with the current install you have. I have changed it already, but does not work. I hope to figure it out eventually.

#15 Updated by bigfoot65 over 8 years ago

Service issue is resolved. It will only be used to start the app. The restart and shutdown will need to be done via the app web UI.

We still have a potential issue with the install script that prevents this from installing correctly. It is being worked.

#16 Updated by eFfeM over 8 years ago

While going through the open bugs I tried sabnzbd+ update test
That one installs fine for me.
I did not try sabnzbd+ itself (was not in my list, guess I have to buy it first)

#17 Updated by bigfoot65 over 8 years ago

Is the install with the latest platform? It should not have worked due to the app dependency being in the app for Fedora RPM Fusion apps.

I have not had success installing it unless I remove the app dependency from the app.

#18 Updated by bigfoot65 over 8 years ago

  • Status changed from New to Feedback

Updated the app to latest version (0.7.1). Please see if it installs correctly. I have tested in 32-bit with success. 64-bit still needs testing.

#19 Updated by guerilla over 8 years ago

just to check bigfoot... you want me to uninstall SABnzbd+ Update Test and reinstall to upgrade to the latest version? will my settings persist?

#20 Updated by bigfoot65 over 8 years ago

Kinda. Only this time, install SABnzbd Plus and not the current one you have installed. The original LIVE app should be fixed now.

http://www.amahi.org/apps/sabnzbd-plus

I will caution you that if you have 64-bit, it may not work. We have been experiencing issues with 64-bit for some reason.

To be safe, you can back up your settings. The app uninstall is designed to do that for you, but never hurts to do it twice.

#21 Updated by bigfoot65 over 8 years ago

Still seems to have issues with 64-bit. See the forum post:
http://forums.amahi.org/viewtopic.php?f=42&t=4111

#22 Updated by cpg over 8 years ago

  • Assignee set to cpg

Hi, we did a couple of updates to the API to accomodate for changes related to Ubuntu. Please try it now. If it works, please close this ticket.

If not, please set it back to assigned to me.

Thanks for your patience!

#23 Updated by guerilla over 8 years ago

will get a chance to install this on 64bit this afternoon will report back.

#24 Updated by cpg over 8 years ago

  • Status changed from Feedback to Closed

Believed to be working. Please update with the details. in the mean time, i'm closing it.

#25 Updated by guerilla about 8 years ago

Just got round to moving over to sabnzdb plus (rather than the update test version). Install goes fine but trying to access the web interface does not work.

@500 Internal Server Error

The server encountered an unexpected condition which prevented it from fulfilling the request.

Traceback (most recent call last):
File "/var/hda/web-apps/sabnzbdplus/html/cherrypy/_cprequest.py", line 618, in respond
cherrypy.response.body = self.handler()
File "/var/hda/web-apps/sabnzbdplus/html/cherrypy/_cpdispatch.py", line 25, in call
return self.callable(*self.args, **self.kwargs)
File "/var/hda/web-apps/sabnzbdplus/html/sabnzbd/interface.py", line 277, in index
if not sabnzbd.newsunpack.PAR2_COMMAND:
File "cheetah__var_hda_web_apps_sabnzbdplus_html_interfaces_Plush_templates_main_tmpl_1348155156_86_22026.py", line 168, in respond
NotFound: cannot find 'have_quota'
Powered by CherryPy 3.2.0@

Any cant get any further.

#26 Updated by guerilla about 8 years ago

going back to the update test I get the same error. copying my backed up version over the files works fine. maybe this is just a problem at my end.

#27 Updated by bigfoot65 about 8 years ago

Is this install on Ubuntu? Also please check the install log for errors.

#28 Updated by bigfoot65 about 8 years ago

I made one change to the app. It should work now.

#29 Updated by bigfoot65 about 8 years ago

  • Status changed from Closed to Feedback

#30 Updated by guerilla about 8 years ago

Just installed now, still get the 500 error. These are the last couple of bits from my log in the hda panel

Processing UserSessionsController#new (for 128.243.253.104 at 2012-09-21 13:31:00) [GET]
Parameters: {"controller"=>"user_sessions", "action"=>"new"}
Rendering template within layouts/login
Rendering user_sessions/new
Completed in 17ms (View: 9, DB: 1) | 200 OK [http://sabnzbd.guerillaunit.co.uk/user_sessions/new]

Processing SetupController#index (for 128.243.253.114 at 2012-09-21 13:34:38) [GET]
Parameters: {"tab"=>"debug", "action"=>"index", "controller"=>"setup", "sub"=>"app_logs"}
Rendering template within layouts/amahi
Rendering setup/index
Completed in 348ms (View: 76, DB: 78) | 200 OK [http://guerillaunit.co.uk/setup?sub=app_logs&tab=debug]

#31 Updated by bigfoot65 about 8 years ago

Please look at /var/log/amahi-app-installer.log file for errors. I just tested and it appears to be working for me.

Did you uninstall, reboot, then reinstall? Also you did not indicate if this is Ubuntu or Fedora.

#32 Updated by guerilla about 8 years ago

Sorry, this is running on the ubuntu version. I have not tried with rebooting in between uninstalling and reinstalling.

#33 Updated by guerilla about 8 years ago

I have just un-installed the test version, rebooted and now installed the live app. everything seems to be working correctly now. Thanks for fixing this.

#34 Updated by bigfoot65 about 8 years ago

  • Status changed from Feedback to Closed

Awesome! Thanks for the confirmation.

Also available in: Atom