Project

General

Profile

Bug #956

VNC one-click install completes but service fails to start

Added by taa about 9 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Apps
Target version:
-
Start date:
08/04/2012
Due date:
% Done:

0%


Description

Amahi on Ubuntu 12.04 server (not desktop), AMD 64bit

Currently has a monitor attached but eventually will run headless.

tail -200 /var/log/amahi-app-installer.log | pastebinit
gives this url: http://paste.ubuntu.com/1130102/

amahi-vnc.jpg View (146 KB) taa, 08/04/2012 09:20 PM

amahi-vnc2.jpg View (106 KB) taa, 08/05/2012 11:40 AM

History

#1 Updated by cpg about 9 years ago

  • Status changed from New to Assigned
  • Assignee set to bigfoot65

#2 Updated by cpg about 9 years ago

@taa, can you try uninstalling and reinstalling?

bigfoot65 made some changes that seems to have fixed it for Ubuntu server.

#3 Updated by taa about 9 years ago

Uninstalled and re-installed. Still won't start. I noted that the version# in the Available Apps list is still 0.9, same as when I initially installed it. Is it supposed to be?

New log extract: http://paste.ubuntu.com/1130240/

#4 Updated by bigfoot65 about 9 years ago

  • Category set to Apps
  • Status changed from Assigned to Feedback

The version is the same, no change there. I found a line that was inadvertently commented out in the install script. Please uninstall, reboot, and reinstall. It should work correctly now.

#5 Updated by taa about 9 years ago

Uninstalled, rebooted, re-installed. It's running now, but when I tried to connect with TightVNC v 1.5.2, I get the attached error. When I click the "logout" button, the error window disappears but the screen with the gray background with three checkboxes in the upper left remain. Subsequent launches of TightVNC no longer give the error, but the gray background screen continues to come up. To be safe, I also updated TightVNC to 2.5.2 and have the same gray background screen.

Also, when I view the installed apps and expand VNC, the special instructions state, "This server runs the desktop as the first Amahi admin user" but that doesn't seem correct in my case. It's running as the SECOND Amahi admin user that I set up, "brj". Now it happens to be the case that "brj" is the first ALPHABETICAL Amahi admin user, but my login, "taa" was the first admin user created, the one that needed to be created during the Amahi install.

#6 Updated by bigfoot65 about 9 years ago

TightVNC may be part of the issue. Can you try another client, such as UltraVNC or similar one. I will check on the first admin issue, that should be easy.

Bug 957 might be part of why this is not working as well.

http://bugs.amahi.org/issues/show/957

The home directory is not properly created for new users. Check your /home and see if it is there with all the pieces like the one initially created with the Ubuntu install.

#7 Updated by bigfoot65 about 9 years ago

Updated the way it selects first admin user. Please uninstall and reinstall. It should pick up the correct one now.

#8 Updated by taa about 9 years ago

  • Status changed from Feedback to Resolved

It's working now -- thank you!

#9 Updated by bigfoot65 over 7 years ago

  • Status changed from Resolved to Closed

Also available in: Atom