Project

General

Profile

Bug #959

12.04 server: GUI Desktop does not start when booting Amahi for the first time

Added by taa about 9 years ago. Updated about 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
08/05/2012
Due date:
% Done:

0%


Description

Ubuntu 12.04 server AMD 64bit, not headless

I carefully followed the install steps here: http://docs.amahi.org/ubuntu-12.html

I got to step 3: "After rebooting, your Amahi HDA (Home Digital Assistant), should be fully working. Now it’s time to set it up. When the system gets to the desktop, there are two links with Amahi logos on them."

The problem is that the GUI desktop doesn't appear so the two links aren't an option.

Screens F1-F6 are character logins. Screen F7 is also character but has the boot log as text.

I =am= able to use Firefox on my Windows PC to bring up the Amahi login screen so it is a workaround for now. Once I log in, I'm presented with the next login stating, "First admin setup. Please re-create your user password." Once I submit the form, the Dashboard appears. I went to Settings and clicked the reboot button; still no GUI desktop on the console.

After doing the very first boot of Amahi, I did the following:

cat /var/log/boot.log|pastebinit

And the results are here: http://paste.ubuntu.com/1131890

Probably not related, but just in case.... Prior to doing a clean install of Ubuntu server, I installed two hard drives:
- /dev/sda - 500GB, to be used exclusively as part of the Greyhole pool
- /dev/sdb - 250GB SSD, contains GRUB, OS and Amahi

What is the proper way to get the GUI desktop to appear so I can do installation step 3 on the main console?

(After reading http://www.amahi.org/faq/is-using-an-ssd-for-amahi-beneficial I'll probably replace the SSD with a regular motor-driven hard drive. I'm leaving it in while I do some experimenting with Amahi.)

History

#1 Updated by bigfoot65 about 9 years ago

  • Status changed from New to Rejected

There won't be a desktop because you installed Ubuntu Server. To access the HDA, you must use a client machine and web browser, navigating to http://hda or http://IP_ADDRESS of the HDA. For the hard drives, it's best to install Ubuntu with only the OS drive connected. You then connect the drives after Ubuntu and Amahi is installed.

This is not a bug and if you want a desktop, you should install Ubuntu Desktop and not Server. This would have been best posted in the forums.

This bug will be closed.

#2 Updated by taa about 9 years ago

There's another possible outcome on this issue -- someone could update step 3 to include information about what to do for the server install. It seems odd to me that only step 1 has desktop v. server install links. If I had known step 3 was not documented correctly, I wouldn't have created a bug report.

For the hard drives, it's best to install Ubuntu with only the OS drive connected.

I didn't see anything documented anywhere about installing with only one drive initially. Did I miss this on the Wiki? Why is it "best" to do so? Just wondering.

#3 Updated by bigfoot65 about 9 years ago

Good point and we need to revise the guidance. As for the drives, with Greyhole it works best if only the OS drive is connected. Otherwise there is risk the OS install will try to take over the other drives as well.

Not saying that the way you installed with the drives will not work. For those who are more experienced, it is usually ok. For those who are not, sometimes it causes issues.

If you would like to help update documentation, we would greatly appreciate your input.

#4 Updated by taa about 9 years ago

I can see what you mean about less advanced users making a mistake when more than one drive is physically mounted during the install.

I'd be glad to help with the documentation; the install steps seem to be on the main amahi.org website vs. being a wiki that others could update. I realize you don't know me from Linus Torvalds or Bill Gates :D and you would understandably not want just anyone to make changes, and they most certainly need to be reviewed and approved before being made "live." In the past, I've used http://www.diigo.com -- would it be workable if I provided "edits" this way, or do you have another procedure? What's easiest for the ever-busy Amahi team?

#5 Updated by cpg about 9 years ago

not sure exactly what page you are referring to. amahi.org has multiple subdomains.

http://wiki.amahi.org is usereditable (though we need to approve new accounts due to spam)

the install docs in http://docs.amahi.org are available in github in: https://github.com/cpg/amahi-docs
from there, you can send a patch, a pull request, etc. if you know github/git. that would be a matter of one click for us, so the easiest.

in the mean time, we added something to section 1 of the Ubuntu install page. See if that's what you meant.

otherwise, diigo is fine if you like that too!

thanks for the kind suggestions!

#6 Updated by bigfoot65 about 9 years ago

  • Status changed from Rejected to Closed

#7 Updated by taa about 9 years ago

I was referring to the page that has the step 3 that caused my confusion. :D

http://docs.amahi.org/ubuntu-12.html

I don't know github/git, but I can learn. :D Thanks for the info about where patches to the install docs can be edited.

Also available in: Atom