Project

General

Profile

Bug #973

Couchpotato cannot rename/ move files and folders from Torrent download folder

Added by achmetinternet about 9 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Apps
Target version:
-
Start date:
09/05/2012
Due date:
% Done:

0%


Description

I don't use NZBs to download content but good old torrent and have set it to Transmission. The download works fine but then the renaming and moving to another folder on my HDA does not work.

I see the following error in the logs of Couchpotato:

OSError: [Errno 13] Permission denied: '/var/hda/files/torrents/FOLDERNAME/FILENAME'

I would really love this to work as the renaming feature of Couch Potato is amazing and would clean up my movie database in a swiffy ;)

changing permissions.jpg View (74.6 KB) achmetinternet, 09/11/2012 12:29 PM

2 no transmission server.jpg View (75.7 KB) achmetinternet, 09/11/2012 12:29 PM

1 transmission installed.jpg View (112 KB) achmetinternet, 09/11/2012 12:29 PM

History

#1 Updated by bigfoot65 about 9 years ago

Have you checked the app settings? It may be something that must be configured by the user.

#2 Updated by bigfoot65 about 9 years ago

  • Priority changed from Medium to Normal

#3 Updated by achmetinternet about 9 years ago

I have checked the settings and I do not see an option related to that. I put correctly the path to where the files should be moved but I assume the Apache user (?) does not have the permission to these folder or something? I have a similar issue unsolved with MiniDLNA whereby I can watch Pictures and Music on my WDTV Live but no Movies.

#4 Updated by achmetinternet about 9 years ago

I would also like to note that I had an issue in the past with Transmission which cpg somehow solved but the Transmission server is also showing as not running (see bug #972 where I had a similar issue).

#5 Updated by achmetinternet about 9 years ago

Okay, now I think I got the issue but not sure how to fix it. My old issue #953 where cpg discussed with me that the transmission-deamon is running as root is related to this. I need Transmission to store the files with such permission that I can remove or delete them or another program like CouchPotato.

Here is a post I found but I do not entirely understand if it will solve my problem.
https://forum.transmissionbt.com/viewtopic.php?f=3&t=6536

I also attach a picture where you can see files that I have just moved into the torrents folder where I have firstadmin:users permission and then a strange www-data:users for the files created by transmission. And even funnier is that after I reinstalled Transmission as a one-click app the newest downloads have the following permission: debian-transmission:debian-transmission!

And after re-install the Transmission server disappeared from the Dashboard.

Will add screens in a second.

#6 Updated by achmetinternet about 9 years ago

Oh and I forgot to add that CouchPotato is able to add movies to transmission for download with my user and PW but cannot move them.

#7 Updated by bigfoot65 about 9 years ago

I checked the app and there is no server feature for Transmission. As for folder permissions, I am unsure what is going on. I have not made any changes other than adding to the cron job.

That would not affect permissions. I am wondering if there was a Transmission package update in Ubuntu that caused this behavior.

#8 Updated by bigfoot65 about 9 years ago

I made some changes. It looks like the Transmission package had changed for Ubuntu recently. Please uninstall and reinstall to see if that fixes your issues,.

The server feature will be absent for now. Once I can confirm everything else is working, I will dig into it.

#9 Updated by achmetinternet about 9 years ago

Ok, I saw the server there before uninstalling it so it definitely was a feature. On the other hand, what did the permissions trick for me was to set the umask=0 in the settings.json file. Now all new files are written with rwx permissions for the group. For the existing files I changed permissions via chmod. So unless there is something realyl nice and new in the new Transmission package I do not want to change it ;)

#10 Updated by bigfoot65 about 9 years ago

Understand. I need someone to test this before I close the bug. I will be checking on the server feature shortly. You must of initially installed this app when Ubuntu first went live. I am guessing it was changed shortly after to remove that feature do to it being broken.

I presume there is a umask line in the .json file, so I will modify that in the app as well. If there is anything I missed, please let me know.

#11 Updated by bigfoot65 about 9 years ago

Found guidance where it stated to set umask at 2. I set it to 0 as you indicated for your install. The server feature looks to be a lost cause as it does not generate a PID file. That is necessary for the feature to work.

I will keep researching it, but for now there will be no server feature.

#12 Updated by bigfoot65 about 9 years ago

  • Status changed from New to Feedback

I think I finally have the server feature working. I changed the umask setting to 2 based on research I found on the internet. If it does not work correctly, I can set it to 0 instead.

Please test if possible.

#13 Updated by achmetinternet about 8 years ago

Will check it on the newer HDA I installed for my boss. On my old HDA the permissions issue was solved by the umask setting in the settings.json file but I fiddled so much around on my old HDA...which is why I want to verify with the clean install on my boss' HDA. But please see the newest bug I posted on Transmission not running as a server or starting at startup, cf. https://bugs.amahi.org/issues/1053

#14 Updated by bigfoot65 over 7 years ago

  • Status changed from Feedback to Closed

No longer updating Amahi 6 apps.

Also available in: Atom