Project

General

Profile

Bug #980

ownCloud hangs on installing

Added by mattman over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
10/06/2012
Due date:
% Done:

0%


Description

After clicking the install button, the installer will hang and not install any of the app, here is the installer-log file, see below, I have more of the log file if needed.

Regards
Matt

======= app install begin @ Fri Oct 05 23:41:06 +0100 2012 ==========
Installing app id mq0pjn4rfr under /var/hda/platform/html ENV=production
WARNING: primary downloaded of http://owncloud.org/releases/owncloud-4.0.7.tar.bz2 barfed with exception "#<Errno::EACCES: Permission denied - /tmp/amahi-download-cache/99b9c5b6b26b75a6ddac610ed47c342e80897c9a>"
WARNING: primary downloaded file /tmp/amahi-download-cache/99b9c5b6b26b75a6ddac610ed47c342e80897c9a did not pass signature check - got badbadsha1, expected 99b9c5b6b26b75a6ddac610ed47c342e80897c9a

History

#1 Updated by bigfoot65 over 8 years ago

There appears to be a connectivity issue. I just checked the download and it's valid as is the sha1sum. I tested in a VM and installed without issue.

#2 Updated by mattman over 8 years ago

I can download manually by using wget but the installer is still giving the same error.
Regards
Matt

#3 Updated by bigfoot65 over 8 years ago

Not sure why it is not working for you. Do you have good connectivity? Might consider purging the download cache. It's located in /tmp/amahi-download directory I believe.

#4 Updated by mattman over 8 years ago

good connectivity never had a problem install other software, lood inside the /tmp/amahi-download-cache folder and it was empty. Any other option that you would like me to try.
Regards
Matt

#5 Updated by bigfoot65 over 8 years ago

  • Status changed from New to Feedback

I cannot reproduce the problem. Only suggestion is to ensure that /var/hda/web-apps does not already have an owncloud directory. Recommend rebooting the HDA and clear browser cache before trying reinstall.

#6 Updated by mattman over 8 years ago

  • Status changed from Feedback to New

done all of the above but still get the same error on the download but the download works maunaly. anything else I could try

#7 Updated by bigfoot65 over 8 years ago

There must be a permissions issue somewhere as I cannot reproduce the error. Do you have issues with any other apps? Also is there any other activity going on when you try to install this app. If so, might be good to stop it temporarily and see if that helps.

#8 Updated by bigfoot65 over 8 years ago

  • Status changed from New to Feedback

Is this resolved? No one else has reported issues.

#9 Updated by mattman over 8 years ago

  • Status changed from Feedback to Closed

Installed the new install version and it install now. I have a different problem on that on the home page of Owncloud I get access forbidden. I will search for this problem and if I can not find anything then I will open a new bug report.

Regards
Matt

#10 Updated by cpg over 8 years ago

@mattman check the error log in the webapp dir for details of the error.

#11 Updated by mattman over 8 years ago

Thanks cpg

checked the error logs and it lead me to the .htaccess file and I had to add this in to get it to work.

<IfModule dir_module>
DirectoryIndex index.php index.html
</IfModule>

All working now
Regards
MattMan

Also available in: Atom