Project

General

Profile

Bug #1078

Updated by cpg almost 9 years ago

I installed the Transnmission on-click-app under Amahi 7.

AMAHI7.

It finishes installing fine, fine. Install log is:

======= app install begin @ 2013-08-12 07:47:05 +0200 ==========
Installing app id csjnit42fq under /var/hda/platform/html ENV=production
Your HDA services have been restarted.
Your HDA services have been restarted.
App: Transmission installed
======= app install end @ 2013-08-12 07:47:12 +0200 ==========

but the server does not start.

the settings folder seems empty:

[jochen@localhost ~]$ cd /var/lib/transmission/

[jochen@localhost transmission]$ cd .config
-bash: cd: .config: No such file or directory
[jochen@localhost transmission]$ ls -al
total 8
drwxr-xr-x 2 transmission transmission 4096 Jul 15 01:22 .
drwxr-xr-x. 28 root root 4096 Aug 7 21:39 ..

more info
[jochen@localhost transmission]$ systemctl status amahi-transmission.service
amahi-transmission.service
Loaded: error (Reason: No such file or directory)
Active: inactive (dead)

some more
[jochen@localhost transmission]$ sudo systemctl status | grep trans | apaste
[sudo] password for jochen:
No text to send.
Traceback (most recent call last):
File "/usr/bin/apaste", line 447, in <module>
main()
File "/usr/bin/apaste", line 414, in main
[url, short_url] = paste(text, options)
TypeError: 'bool' object is not iterable

[jochen@localhost transmission]$ sudo systemctl status | grep trans

[jochen@localhost transmission]$ systemctl status | grep trans

[jochen@localhost transmission]$ rpm -qa | grep trans
transmission-common-2.80-2.fc19.x86_64
transmission-daemon-2.80-2.fc19.x86_64

the log error log file in /var/hda/web-apps/transmission/logs/ shows

[Mon Aug 12 09:11:52.344676 2013] [proxy:error] [pid 7618] (111)Connection refused: AH00957: HTTP: attempt to connect to 127.0.0.1:9091 (127.0.0.1) failed
[Mon Aug 12 09:11:52.344840 2013] [proxy:error] [pid 7618] AH00959: ap_proxy_connect_backend disabling worker for (127.0.0.1) for 60s
[Mon Aug 12 09:11:52.344891 2013] [proxy_http:error] [pid 7618] [client 192.168.178.149:37555] AH01114: HTTP: failed to make connection to backend: 127.0.0.1, referer: http://hda.thuiz.com/
[Mon Aug 12 09:11:52.615340 2013] [proxy:error] [pid 7499] (111)Connection refused: AH00957: HTTP: attempt to connect to 127.0.0.1:9091 (127.0.0.1) failed
[Mon Aug 12 09:11:52.615439 2013] [proxy:error] [pid 7499] AH00959: ap_proxy_connect_backend disabling worker for (127.0.0.1) for 60s
[Mon Aug 12 09:11:52.615474 2013] [proxy_http:error] [pid 7499] [client 192.168.178.149:37556] AH01114: HTTP: failed to make connection to backend: 127.0.0.1
(END)

the access log looks like:
192.168.178.149 - - [12/Aug/2013:09:11:52 +0200] "GET / HTTP/1.1" 503 299 "http://hda.thuiz.com/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/28.0.1500.71 Chrome/28.0.1500.71 Safari/537.36"
192.168.178.149 - - [12/Aug/2013:09:11:52 +0200] "GET /favicon.ico HTTP/1.1" 503 299 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/28.0.1500.71 Chrome/28.0.1500.71 Safari/537.36"

Back