Project

General

Profile

Bug #1588

Updated by cpg over 6 years ago

i tried to install usermin and i get all this cr@ap on the install log:

<pre>
Installing app id 03adu5t74q under /var/hda/platform/html/script/.. ENV=production
file /var/hda/tmp/amahi-download-cache/4c88d6a41929c68332cc45e58b17c8f88b78efe8 picked up from cache.
Your HDA services have been restarted.
Your HDA services have been restarted.
/tmp/run_script20141212-14938-epyo4b: line 1: $'\r': command not found
/tmp/run_script20141212-14938-epyo4b: line 2: $'\r': command not found
/tmp/run_script20141212-14938-epyo4b: line 3: $'\r': command not found
/tmp/run_script20141212-14938-epyo4b: line 23: $'\r': command not found
/tmp/run_script20141212-14938-epyo4b: line 24: $'\r': command not found
/var/hda/web-apps/usermin/elevated/start.sh: line 1: $'\r': command not found
Enabling usermin service
/var/hda/web-apps/usermin/elevated/start.sh: line 2: $'\r': command not found
/var/hda/web-apps/usermin/elevated/start.sh: line 3: $'\r': command not found
Configuring Amahi settings
/var/hda/web-apps/usermin/elevated/start.sh: line 4: $'\r': command not found
/var/hda/web-apps/usermin/elevated/start.sh: line 5: $'\r': command not found
/var/hda/web-apps/usermin/elevated/start.sh: line 11: $'\r': command not found
/var/hda/web-apps/usermin/elevated/start.sh: line 12: $'\r': command not found
Reloading systemctl daemon
/var/hda/web-apps/usermin/elevated/start.sh: line 13: $'\r': command not found
/var/hda/web-apps/usermin/elevated/start.sh: line 14: $'\r': command not found
/var/hda/web-apps/usermin/elevated/start.sh: line 15: $'\r': command not found
Starting usermin service
/var/hda/web-apps/usermin/elevated/start.sh: line 16: $'\r': command not found
/var/hda/web-apps/usermin/elevated/start.sh: line 17: $'\r': command not found
/tmp/run_script20141212-14938-epyo4b: line 25: $'\r': command not found
/tmp/run_script20141212-14938-epyo4b: line 26: $'\r': command not found
/tmp/run_script20141212-14938-epyo4b: line 27: $'\r': command not found
/tmp/run_script20141212-14938-epyo4b: line 28: $'\r': command not found
App: Usermin installed
</pre>

i cannot see what this is about, but this is clearly badness somewhere.

also, i
see the url is http://usermin.amahi.net .. but it appears to redirect automatically to https://usermin.amahi.net:20000

i really think we have to forbid this type of thing in apps. not only goes for https, also some high port that we can't do much about.

can you investigate why this happens?

Back